summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-block_is_expected
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
commitb83e82c4d46297f4fbe56dc8b6e149637d5d90fd (patch)
tree147ed0e44f1ffb8bfbb03c75e5a308d2138f3884 /dev-ruby/rspec-block_is_expected
parentdb970551c403ad46231ff09b63717be8c11351d3 (diff)
gentoo auto-resync : 29:04:2023 - 11:14:33
Diffstat (limited to 'dev-ruby/rspec-block_is_expected')
-rw-r--r--dev-ruby/rspec-block_is_expected/Manifest3
-rw-r--r--dev-ruby/rspec-block_is_expected/metadata.xml11
-rw-r--r--dev-ruby/rspec-block_is_expected/rspec-block_is_expected-1.0.5.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/rspec-block_is_expected/Manifest b/dev-ruby/rspec-block_is_expected/Manifest
new file mode 100644
index 000000000000..1011aa426207
--- /dev/null
+++ b/dev-ruby/rspec-block_is_expected/Manifest
@@ -0,0 +1,3 @@
+DIST rspec-block_is_expected-1.0.5.tar.gz 20486 BLAKE2B 6ec1ffb606c646aae6f63845697d461946a7a3574b82506207f81f49c6d50282370b716f1d124b98cb19b79591522caf408fa978b2c0b423a3d6c9b986b32272 SHA512 4423948605ca58e15d4b6994cce6850487e72c265feda6461e6614374af4a6fef22329e1d62668b4930273c3f0f68348fdacaf67acbd4eeff771c8779d007194
+EBUILD rspec-block_is_expected-1.0.5.ebuild 666 BLAKE2B 668cb00c06c94d9448c97ff98461691ec0741c14b8d4dc8fee1bc8f9986e9d98504b3f97331d3027b1166e15fc9105da569cb686a962c13e711de123e3118b29 SHA512 d966291f5c548bb29e701bcc60c9a4ac1cc3c029e5cf07eabe458dcc55599511e417201d0c7af653687d7432afdfc5eb4e6271e802af561fdded4cbf8675ace6
+MISC metadata.xml 358 BLAKE2B a4611fe41604c9274a27b0d3b578e66eb9568c1b98036e60667e057c53c71e45090d06db5c6805ac31c65c332fb656de7433831c75cf5900ab573f16e5d31f7f SHA512 49646557b7db7548432feb7c73cfd10af4e2e992c8d8923deee995dcf680bec7343a43600b8c86cb9d61af7922ca419dc7f5608fda488db49a4f5467712a3bf9
diff --git a/dev-ruby/rspec-block_is_expected/metadata.xml b/dev-ruby/rspec-block_is_expected/metadata.xml
new file mode 100644
index 000000000000..c672ba5197f4
--- /dev/null
+++ b/dev-ruby/rspec-block_is_expected/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pboling/rspec-block_is_expected</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-block_is_expected/rspec-block_is_expected-1.0.5.ebuild b/dev-ruby/rspec-block_is_expected/rspec-block_is_expected-1.0.5.ebuild
new file mode 100644
index 000000000000..56505a35e475
--- /dev/null
+++ b/dev-ruby/rspec-block_is_expected/rspec-block_is_expected-1.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="rspec-block_is_expected.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simplify testing of blocks in RSpec"
+HOMEPAGE="https://github.com/pboling/rspec-block_is_expected"
+SRC_URI="https://github.com/pboling/rspec-block_is_expected/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+SLOT="1"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+ruby_add_depend "test? ( >=dev-ruby/rspec-pending_for-0.1:0 )"