summaryrefslogtreecommitdiff
path: root/dev-ruby/rqrcode_core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ruby/rqrcode_core
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ruby/rqrcode_core')
-rw-r--r--dev-ruby/rqrcode_core/Manifest3
-rw-r--r--dev-ruby/rqrcode_core/metadata.xml8
-rw-r--r--dev-ruby/rqrcode_core/rqrcode_core-0.1.0.ebuild28
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/rqrcode_core/Manifest b/dev-ruby/rqrcode_core/Manifest
new file mode 100644
index 000000000000..45478dde4ebe
--- /dev/null
+++ b/dev-ruby/rqrcode_core/Manifest
@@ -0,0 +1,3 @@
+DIST rqrcode_core-0.1.0.tar.gz 20241 BLAKE2B 1d6f97cd8e1188c0a3ba0246d2102a901ac64fb0bb08317479f9061d3273ea49388e4a6ea02c8de6b54f8e928aefab62fe8b0dca8ba9f7ed31625cf84965df4b SHA512 30ba73f45d69360b0efbf543a774c709a4397bd8f726f4edeaa830397187cd5c7535ac5816d65cea00f356f7111f69629f03fa508b7a7fc91d5618c4cebd8167
+EBUILD rqrcode_core-0.1.0.ebuild 654 BLAKE2B b04d021e0cd5764254fbb2bdf2b18107fc86349bee666ad877b53276fcacd53f6f00ef6a02b23c8d74e2d78a87b2e1e2f3eb385d9be70bcc864da00df63971c9 SHA512 37ad08dea75e5d18a935ce0ea26f28e68f1dbf9e741e34e43865b4ae732235d0f1d333929a6acc95717bc0683d14e0ee7c5eec3ab7e530c481c08de4fb7429bb
+MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/rqrcode_core/metadata.xml b/dev-ruby/rqrcode_core/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/rqrcode_core/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/rqrcode_core/rqrcode_core-0.1.0.ebuild b/dev-ruby/rqrcode_core/rqrcode_core-0.1.0.ebuild
new file mode 100644
index 000000000000..58979b3170b3
--- /dev/null
+++ b/dev-ruby/rqrcode_core/rqrcode_core-0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rqrcode_core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="https://github.com/whomwah/rqrcode_core/"
+SRC_URI="https://github.com/whomwah/rqrcode_core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}