summaryrefslogtreecommitdiff
path: root/dev-ruby/rouge/rouge-3.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-ruby/rouge/rouge-3.7.0.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-ruby/rouge/rouge-3.7.0.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-3.7.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-3.7.0.ebuild b/dev-ruby/rouge/rouge-3.7.0.ebuild
new file mode 100644
index 000000000000..ffabec94cfef
--- /dev/null
+++ b/dev-ruby/rouge/rouge-3.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+ruby_add_rdepend "dev-ruby/redcarpet
+ !!<dev-ruby/rouge-1.11.1-r2:0"
+
+all_ruby_prepare() {
+ rm -f tasks/update/changelog.rake || die
+
+ sed -i -e '/bundler/I s:^:#: ; 5irequire "minitest-power_assert"' spec/spec_helper.rb || die
+ sed -i -e '/\(changelog\|bundler\)/ s:^:#: ; 1irequire "pathname"' Rakefile || die
+}