summaryrefslogtreecommitdiff
path: root/dev-ruby/rouge/rouge-3.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-ruby/rouge/rouge-3.6.0.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-ruby/rouge/rouge-3.6.0.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-3.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-3.6.0.ebuild b/dev-ruby/rouge/rouge-3.6.0.ebuild
new file mode 100644
index 000000000000..fb11aff5040d
--- /dev/null
+++ b/dev-ruby/rouge/rouge-3.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+ruby_add_rdepend "dev-ruby/redcarpet
+ !!<dev-ruby/rouge-1.11.1-r2:0"
+
+all_ruby_prepare() {
+ rm -f tasks/changelog.rake || die
+
+ sed -i -e '/bundler/I s:^:#: ; 5irequire "minitest-power_assert"' spec/spec_helper.rb || die
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}