summaryrefslogtreecommitdiff
path: root/dev-ruby/rouge/rouge-3.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:31:11 +0100
commitad6182343997a405079870a2fe91c4e0c6b94595 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /dev-ruby/rouge/rouge-3.11.0.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'dev-ruby/rouge/rouge-3.11.0.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-3.11.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-3.11.0.ebuild b/dev-ruby/rouge/rouge-3.11.0.ebuild
new file mode 100644
index 000000000000..1ba7cbc90225
--- /dev/null
+++ b/dev-ruby/rouge/rouge-3.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+RUBY_FAKEGEM_GEMSPEC="rouge.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )
+ test? ( dev-ruby/minitest-power_assert )
+ dev-ruby/yard
+"
+
+ruby_add_rdepend "dev-ruby/redcarpet"
+
+all_ruby_prepare() {
+ rm -f tasks/{check/style,update/changelog}.rake || die
+
+ sed -i -e '/bundler/I s:^:#: ; 5irequire "minitest-power_assert"' spec/spec_helper.rb || die
+ sed -i -e '/\(changelog\|bundler\|rubocop\)/ s:^:#: ; 1irequire "pathname"' Rakefile || die
+}