summaryrefslogtreecommitdiff
path: root/dev-ruby/rouge/rouge-3.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-ruby/rouge/rouge-3.10.0.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-ruby/rouge/rouge-3.10.0.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-3.10.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-3.10.0.ebuild b/dev-ruby/rouge/rouge-3.10.0.ebuild
new file mode 100644
index 000000000000..645508576068
--- /dev/null
+++ b/dev-ruby/rouge/rouge-3.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+RUBY_FAKEGEM_GEMSPEC="rouge.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )
+ test? ( dev-ruby/minitest-power_assert )
+"
+
+ruby_add_rdepend "dev-ruby/redcarpet"
+
+all_ruby_prepare() {
+ rm -f tasks/update/changelog.rake || die
+
+ sed -i -e '/bundler/I s:^:#: ; 5irequire "minitest-power_assert"' spec/spec_helper.rb || die
+ sed -i -e '/\(changelog\|bundler\)/ s:^:#: ; 1irequire "pathname"' Rakefile || die
+}