summaryrefslogtreecommitdiff
path: root/dev-ruby/rotp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-ruby/rotp
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-ruby/rotp')
-rw-r--r--dev-ruby/rotp/Manifest3
-rw-r--r--dev-ruby/rotp/metadata.xml16
-rw-r--r--dev-ruby/rotp/rotp-6.2.0.ebuild36
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/rotp/Manifest b/dev-ruby/rotp/Manifest
new file mode 100644
index 000000000000..88a7f61abf17
--- /dev/null
+++ b/dev-ruby/rotp/Manifest
@@ -0,0 +1,3 @@
+DIST rotp-6.2.0.tar.gz 60000 BLAKE2B dba270201593425c9282aca71efb33ecacda916996ebfffc703dd865a6c6ee3b3da4098497ce036a95157089d8d736e9413d0aa9fd0dc582d4b278ce811e05d0 SHA512 938cf9feffbe7e86f542c6dde4cd87b57e2ddd2696303e69cb76bc9fb04ffb40c9a5ef45288f23cb096d9f6706e0b48ad89907dc9322594df10c8c0521feffa1
+EBUILD rotp-6.2.0.ebuild 858 BLAKE2B 146db7bc372c6ffe03d9041d9b1d5e4edecd3d7d48abf87dc6ea405186144b520416ae3009967bdfccbd0afa20b481ff349d9d9e8ccd16eb57a6541e071b1414 SHA512 60c9f2573964dd69c0d33b14158434da4e536aa817f137fe79802c3d599b08f8d191040ce454c6c42d332e764d19d78e219ad73383e82728f9eb5d91a14ee50e
+MISC metadata.xml 525 BLAKE2B 573d42b41ba0fbca4405ab859f12793a175791b2dd3ae72eb69b9a1c85460ee6f235fc76a59acefa68e05ede0ec5872ff3878caf9086f576a9c1d588bc6d7cba SHA512 b3d84c83bdd186ecebe8adde73d27be759440a3ea36594fce4656b5ad1b4e476fdfaca85e76e8ef9b36490e6990cb3da3ef612010060b96850f6330e6315ebe5
diff --git a/dev-ruby/rotp/metadata.xml b/dev-ruby/rotp/metadata.xml
new file mode 100644
index 000000000000..e6795abd2b98
--- /dev/null
+++ b/dev-ruby/rotp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mdp/rotp</remote-id>
+ <remote-id type="rubygems">rotp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rotp/rotp-6.2.0.ebuild b/dev-ruby/rotp/rotp-6.2.0.ebuild
new file mode 100644
index 000000000000..cf584132bc38
--- /dev/null
+++ b/dev-ruby/rotp/rotp-6.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Ruby One Time Password Library"
+HOMEPAGE="https://github.com/mdp/rotp"
+SRC_URI="https://github.com/mdp/rotp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/openssl"
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/timecop-0.8 )
+"
+
+all_ruby_prepare() {
+ # Remove simplecov
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+ # Don't require git
+ sed -i \
+ -e 's/git ls-files/find/' \
+ -e 's/{test,spec,features}/spec/' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+}