summaryrefslogtreecommitdiff
path: root/dev-ruby/rjb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-ruby/rjb
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-ruby/rjb')
-rw-r--r--dev-ruby/rjb/Manifest1
-rw-r--r--dev-ruby/rjb/rjb-1.6.4.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-ruby/rjb/Manifest b/dev-ruby/rjb/Manifest
index 8ce68f8b24fb..2b34163d6992 100644
--- a/dev-ruby/rjb/Manifest
+++ b/dev-ruby/rjb/Manifest
@@ -1,4 +1,3 @@
DIST rjb-1.6.4.gem 75264 BLAKE2B a678eb0b57e930bfcc7ea059da8ee6a9319b7e0e5bc632a5b97ec617e77d844491469ebc2366ba4290ee7648b4201f1d34be560e325c6099237d413c9ed8aa46 SHA512 49a0aaeb1a0e945ce373af74e01f33f531e27b205c33a382975125357ee1ceae0bea12d6fc32acb2dd66ce56c6034691520f355688cdaca5d01abff295d1a6c8
EBUILD rjb-1.6.4-r1.ebuild 1914 BLAKE2B a77cec9382c95bdeb570292d487a28737e24b9f3a2053794ab7ce226cfa10f8c5e1445e3e52a8be57254fa7908468b02cced941998a7b4e7e0cdca81bf8d191f SHA512 e0f825ece719016ec9704eec7a95b35f3b0085b3cb94cbe60bc25201262c77eb25bf132af01885d5c911c15a9f56bccfee65dc194d14f737538edb74a29f6eac
-EBUILD rjb-1.6.4.ebuild 1906 BLAKE2B 3b996ac28efac9d1c22328b16e3a787566f2a2fac2caaedf97358c9778ad24e210e8d0d0fb959ddc33d53b658877db21325a8c61158b56a049ed1c6c6210883d SHA512 2872f03676a465f880dff18f8fe0bf869acdb714aca8e0f7da987064d3987e352a8cee0b7e60c358a9887bad44087b26502a3e695fa6969b7b776ad2cb0f654e
MISC metadata.xml 433 BLAKE2B f23feff51bbe88032b365e2cd7989e91f0d09bc20a9d0f3a3084b593d5c94e220ab86f26cf8bb6ad37044130f17b4a2724d339f36805778a739fc3755b8b94b6 SHA512 9e71bf1595b1f96faf1a13f69c4a045ad498382a196a2ec6960c85909c699ae4d49c25b993130ad2328c565862186ce6343f64baba8c9c6fa83c1954960b7264
diff --git a/dev-ruby/rjb/rjb-1.6.4.ebuild b/dev-ruby/rjb/rjb-1.6.4.ebuild
deleted file mode 100644
index b7a47f4edfd6..000000000000
--- a/dev-ruby/rjb/rjb-1.6.4.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
-
-inherit java-pkg-2 ruby-fakegem
-
-DESCRIPTION="Rjb is a Ruby-Java software bridge"
-HOMEPAGE="https://github.com/arton/rjb"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples hardened"
-
-DEPEND=">=virtual/jdk-1.5
- hardened? ( sys-apps/paxctl )"
-RDEPEND="virtual/jre"
-
-pkg_setup() {
- ruby-ng_pkg_setup
- java-pkg-2_pkg_setup
-}
-
-all_ruby_prepare() {
- # The console is not available for testing.
- sed -i -e '/test_noarg_sinvoke/,/end/ s:^:#:' test/test.rb || die
-
- # Avoid encoding tests since not all locales may be available.
- sed -i -e '/test_kjconv/,/^ end/ s:^:#:' test/test.rb || die
-
- # Fix build on openjdk-11
- sed -i -e 's#javah -classpath ../data/rjb jp.co.infoseek.hp.arton.rjb.RBridge#javac -h . -classpath ../data/rjb RBridge.java#g' ext/extconf.rb || die
-}
-
-each_ruby_prepare() {
- #dev-lang/ruby might need the "hardened" flag to enforce the following:
- if use hardened; then
- paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb will only work if ruby is MPROTECT disabled\n please disable it if required using paxctl -m /usr/bin/ruby'
- fi
- # force compilation of class file for our JVM
- rm -rf data
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- if use examples; then
- dodoc -r samples
- fi
-}
-
-each_ruby_test() {
- if use hardened; then
- paxctl -v ${RUBY} 2>/dev/null | grep MPROTECT | grep -q disabled
- if [ $? = 0 ]; then
- ${RUBY} -C test -I../lib:.:../ext test.rb || die
- else
- ewarn "${RUBY} has MPROTECT enabled, rjb will not work until it is disabled, skipping tests."
- fi
- else
- ${RUBY} -C test -I../lib:.:../ext test.rb || die
- fi
-}