summaryrefslogtreecommitdiff
path: root/dev-ruby/rjb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/rjb
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/rjb')
-rw-r--r--dev-ruby/rjb/Manifest5
-rw-r--r--dev-ruby/rjb/metadata.xml15
-rw-r--r--dev-ruby/rjb/rjb-1.5.5.ebuild81
3 files changed, 101 insertions, 0 deletions
diff --git a/dev-ruby/rjb/Manifest b/dev-ruby/rjb/Manifest
new file mode 100644
index 000000000000..8fc9178198a2
--- /dev/null
+++ b/dev-ruby/rjb/Manifest
@@ -0,0 +1,5 @@
+DIST rjb-1.5.5.gem 73216 SHA256 8a81557cccf06e06435202cedffe3dcda780a9abe3b803a1057c48165746f2de SHA512 a1a8f6e6b75555ce228fe8d58b467f783e55ddb12371485d45ad32597ea7ec60d30e3870671455e4e22fd680b5aa21bd952b8abfa36531c030747573e5d43cea WHIRLPOOL cb146672bc02838fa8ef3f14f972abc0566bbdf25543fddd82569c67bc3835c4b681258b7303392a53315f73b6cfadac7ee40cb69281096ea47310af2b2b8b6e
+EBUILD rjb-1.5.5.ebuild 2035 SHA256 e08654b95f8da64552285a6ab51d722b1610cd4f128366c8a31ffe5b4fdc6bcc SHA512 5641e7547e126a19981f5d60a0a9de77f857a524d73b192defc9f8300f6edd582b68121aa21a44e29a8c2432c101007529af7d3b4244aa3c86d85d7f0e878927 WHIRLPOOL 4289e020878bdc830d3313d21528ca089482f18b36db40324992da57fa86969d7056df595faf62a6ac4017a123d833f2df1184058911939ad20c5d5b41080807
+MISC ChangeLog 3642 SHA256 31aff175b6894c76a88e1ff464050bc8ad44708120df907aa9aaad982e4f0292 SHA512 865bf3ceb8065f68db5b94bafb647b833edabdec6465a2bf0958c261467e05a1303f1351f8f31b87747eaa3dd5c9eca1654ff1c00cb509294d54ea3b24bafc67 WHIRLPOOL 87265027bdefaba719bc69edb85137df83ee98a21ef025d279dea0701a530816326c203071b8d4326c0e0772e2f108f14301231b44c347b39f7bc1543d92c1a5
+MISC ChangeLog-2015 1099 SHA256 16de65c4ed42a462f77a3ba394af0278c549cd0463900570a3b1d9d2907bc8df SHA512 1a3c28dea726549163293ec09b9cf80cffd54bcb1893be4e8975ab3c0b5f0321cdaf48f182434aa9d18338657afcd130371467494a42da878d7b2bbc879c10e7 WHIRLPOOL 4a84cd5ee5fe7c12f9c937c7cfcecd4e72b776a3ed80e351ee24de34aafcde6937e698826b9eda48555f85a3a93f4f0d04ebceae3319bfea6610e487dc709fc0
+MISC metadata.xml 433 SHA256 01b9ecdbc3319f6803844cc5ec891071e04cb7f912db9e508c57cafa5edd607a SHA512 9e71bf1595b1f96faf1a13f69c4a045ad498382a196a2ec6960c85909c699ae4d49c25b993130ad2328c565862186ce6343f64baba8c9c6fa83c1954960b7264 WHIRLPOOL db53c563023a805f89242e813da2039dbf81c84f8ab6e6d1502f299c9a6f43bfcc0e6296feb659297e8cd82a654e756f26484f1b4ff673d7ee66b7de40def814
diff --git a/dev-ruby/rjb/metadata.xml b/dev-ruby/rjb/metadata.xml
new file mode 100644
index 000000000000..33ee57fbbc36
--- /dev/null
+++ b/dev-ruby/rjb/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">arton/rjb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rjb/rjb-1.5.5.ebuild b/dev-ruby/rjb/rjb-1.5.5.ebuild
new file mode 100644
index 000000000000..524297c5ca03
--- /dev/null
+++ b/dev-ruby/rjb/rjb-1.5.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit java-pkg-2 ruby-ng ruby-fakegem
+
+DESCRIPTION="Rjb is a Ruby-Java software bridge"
+HOMEPAGE="https://github.com/arton/rjb"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples hardened"
+
+DEPEND=">=virtual/jdk-1.5
+ hardened? ( sys-apps/paxctl )"
+RDEPEND="virtual/jre"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+all_ruby_prepare() {
+ # The console is not available for testing.
+ sed -i -e '/test_noarg_sinvoke/,/end/ s:^:#:' test/test.rb || die
+
+ # Avoid encoding tests since not all locales may be available.
+ sed -i -e '/test_kjconv/,/^ end/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_prepare() {
+ #dev-lang/ruby might need the "hardened" flag to enforce the following:
+ if use hardened; then
+ paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb will only work if ruby is MPROTECT disabled\n please disable it if required using paxctl -m /usr/bin/ruby'
+ fi
+ # force compilation of class file for our JVM
+ rm -rf data
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # currently no elegant way to do this (bug #352765)
+ ruby_fakegem_newins ext/rjbcore.so lib/rjbcore.so
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
+
+each_ruby_test() {
+ if use hardened; then
+ paxctl -v ${RUBY} 2>/dev/null | grep MPROTECT | grep -q disabled
+ if [ $? = 0 ]; then
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ else
+ ewarn "${RUBY} has MPROTECT enabled, rjb will not work until it is disabled, skipping tests."
+ fi
+ else
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ fi
+}