summaryrefslogtreecommitdiff
path: root/dev-ruby/rjb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ruby/rjb
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ruby/rjb')
-rw-r--r--dev-ruby/rjb/Manifest2
-rw-r--r--dev-ruby/rjb/rjb-1.5.7.ebuild81
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-ruby/rjb/Manifest b/dev-ruby/rjb/Manifest
index 12bb12131713..2a1298a4ce42 100644
--- a/dev-ruby/rjb/Manifest
+++ b/dev-ruby/rjb/Manifest
@@ -1,5 +1,3 @@
-DIST rjb-1.5.7.gem 72704 BLAKE2B 9a4f2b304c05f65c0d78ca4909814da366de717f518017c73d23cfcf188d653141d6c4549200c4bd3e55421f59cf8442cf2d01c1c5c1be813964ee7fb4a7b501 SHA512 0ccdbb5bc6f9f5d914d5b117c96310d709965b81a4bd2d0d7c428aabf4e32672572d4187660bc1b509fa3c92ac4cbe97cbd98412253d4ec9a7e4981f3b7a3131
DIST rjb-1.6.1.gem 74240 BLAKE2B 103e3885634be9c7dd842c2737c420511fea04e4e2d18f77dba7689c47da996fa37af5d08827de21ec38effd3fd99407e99491c8b99d134dded219ccf3880b79 SHA512 5b78fc4eabceddeb901145af39b1fc76e9a44801596ea4bacf9ce601cc109107cf042b1aa4c27049abd766ffca3206364079866ce7b88d25657fa75e7593adc3
-EBUILD rjb-1.5.7.ebuild 2039 BLAKE2B 8983ec30b45a3566cc08438dbdd52f76aa910ab2a92c29325781776eedc98484c83939ddfc4fc4c385145b2b6cb35b68c02b9be0e39b6f2edd53c9efa0f3a77f SHA512 3e0c7a0f8342f6e191dfaa0f33c1a17c2f1d4aa7ef2b92abc9155f3bb8e52c856aa7b9c4b4de42564db821bc5929ca63f19556383119bdca18abf087fc7fde94
EBUILD rjb-1.6.1.ebuild 2156 BLAKE2B 6be233ff05435ad3911ac10bc5a3e3296e46ce8a2a6f8e985d630f0a19736300fcbfaa88026d608e77e192700ce744c6031b5a1d8ebbcb4da392a69ba0fd8b5a SHA512 779a6addb448832a41a5a117f27fba090eab184ac59b0feae46b0377f97c50dfcd24ff4e39a9d5116f078c649256dd521411dfc67e4261f551009f8dd2baaac6
MISC metadata.xml 433 BLAKE2B f23feff51bbe88032b365e2cd7989e91f0d09bc20a9d0f3a3084b593d5c94e220ab86f26cf8bb6ad37044130f17b4a2724d339f36805778a739fc3755b8b94b6 SHA512 9e71bf1595b1f96faf1a13f69c4a045ad498382a196a2ec6960c85909c699ae4d49c25b993130ad2328c565862186ce6343f64baba8c9c6fa83c1954960b7264
diff --git a/dev-ruby/rjb/rjb-1.5.7.ebuild b/dev-ruby/rjb/rjb-1.5.7.ebuild
deleted file mode 100644
index c2f79b950d94..000000000000
--- a/dev-ruby/rjb/rjb-1.5.7.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-inherit java-pkg-2 ruby-ng ruby-fakegem
-
-DESCRIPTION="Rjb is a Ruby-Java software bridge"
-HOMEPAGE="https://github.com/arton/rjb"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples hardened"
-
-DEPEND=">=virtual/jdk-1.5
- hardened? ( sys-apps/paxctl )"
-RDEPEND="virtual/jre"
-
-pkg_setup() {
- ruby-ng_pkg_setup
- java-pkg-2_pkg_setup
-}
-
-all_ruby_prepare() {
- # The console is not available for testing.
- sed -i -e '/test_noarg_sinvoke/,/end/ s:^:#:' test/test.rb || die
-
- # Avoid encoding tests since not all locales may be available.
- sed -i -e '/test_kjconv/,/^ end/ s:^:#:' test/test.rb || die
-}
-
-each_ruby_prepare() {
- #dev-lang/ruby might need the "hardened" flag to enforce the following:
- if use hardened; then
- paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb will only work if ruby is MPROTECT disabled\n please disable it if required using paxctl -m /usr/bin/ruby'
- fi
- # force compilation of class file for our JVM
- rm -rf data
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}"
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- # currently no elegant way to do this (bug #352765)
- ruby_fakegem_newins ext/rjbcore.so lib/rjbcore.so
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r samples
- fi
-}
-
-each_ruby_test() {
- if use hardened; then
- paxctl -v ${RUBY} 2>/dev/null | grep MPROTECT | grep -q disabled
- if [ $? = 0 ]; then
- ${RUBY} -C test -I../lib:.:../ext test.rb || die
- else
- ewarn "${RUBY} has MPROTECT enabled, rjb will not work until it is disabled, skipping tests."
- fi
- else
- ${RUBY} -C test -I../lib:.:../ext test.rb || die
- fi
-}