summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-exploitation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/rex-exploitation
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/rex-exploitation')
-rw-r--r--dev-ruby/rex-exploitation/Manifest3
-rw-r--r--dev-ruby/rex-exploitation/metadata.xml12
-rw-r--r--dev-ruby/rex-exploitation/rex-exploitation-0.1.12.ebuild30
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/rex-exploitation/Manifest b/dev-ruby/rex-exploitation/Manifest
new file mode 100644
index 000000000000..ad08f1ef4054
--- /dev/null
+++ b/dev-ruby/rex-exploitation/Manifest
@@ -0,0 +1,3 @@
+DIST rex-exploitation-0.1.12.gem 78848 SHA256 087fa124f9c383db8b8cda78e934393800174c06e9b7739dfc4be2b778c29eb8 SHA512 74716b4f23cb490fbc84e37269b12c58ce83ff903cf37b84685bc59838fe6c45f91082db063f9ced5e8270af6b27dad1cc6b836fb470a9a59be7c039f9ed7b2c WHIRLPOOL f3473c07a48d4ab4ea20686602fe4a3ed12e1a98c8170fdb81e95c45889ac27b6fd9214d2a00ad14aafba24d82d8d6e2d8d4e7161403ccf68b126bfebdbd476b
+EBUILD rex-exploitation-0.1.12.ebuild 598 SHA256 5c4595ffd7f9c308f288dce86b16af8693bca276cac6030d79aaa826337915d1 SHA512 2d9fbe81be7f836c29a158e529631b9ec3c4145ba7680d6aa6f1494efcfbc6f6032e3023823cf2155eea9a3056285bd424df9598ac498f48cf1f017859740ff2 WHIRLPOOL af195547a7f516d30cfa9dbb8ad120f3b865eb77959b2f9c2dc25cb1775f86c13680cfc9f34ceb019b2bcecdedb19c954f65c1ead1257b71604313d7f5c57b9a
+MISC metadata.xml 405 SHA256 67c18cf86095a15eab0478ad7b5d7af407387b475a9d4e83bf9299b9fb29d47e SHA512 3af40e7e532b1d0c141aa419cdd5f10dc151c3406e90bc56e7e281a78e8fca7e8204213d6e0ffc6ed74ae4d0ca6a9bc79c5c4760be0406b0d89694d0299d5c85 WHIRLPOOL 78754243e520bee30eadfb1c13165521885b981e829ca1352f2ae3cb3f21c76dc8567fa2761133bdeccad3b447ec9b10f08f7f2c85c0479a85f0665e1edf6bd0
diff --git a/dev-ruby/rex-exploitation/metadata.xml b/dev-ruby/rex-exploitation/metadata.xml
new file mode 100644
index 000000000000..ca2ed33abcc1
--- /dev/null
+++ b/dev-ruby/rex-exploitation/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rapid7/rex-exploitation</remote-id>
+ <remote-id type="rubygems">rex-exploitation</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rex-exploitation/rex-exploitation-0.1.12.ebuild b/dev-ruby/rex-exploitation/rex-exploitation-0.1.12.ebuild
new file mode 100644
index 000000000000..111719427438
--- /dev/null
+++ b/dev-ruby/rex-exploitation/rex-exploitation-0.1.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="various helper mechanisms for creating exploits"
+HOMEPAGE="https://rubygems.org/gems/rex-exploitation"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT="test"
+
+ruby_add_rdepend "dev-ruby/jsobfu
+ dev-ruby/metasm:*
+ dev-ruby/rex-arch
+ dev-ruby/rex-encoder
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}