summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-exploitation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /dev-ruby/rex-exploitation
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'dev-ruby/rex-exploitation')
-rw-r--r--dev-ruby/rex-exploitation/Manifest2
-rw-r--r--dev-ruby/rex-exploitation/rex-exploitation-0.1.20.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/rex-exploitation/Manifest b/dev-ruby/rex-exploitation/Manifest
index e647b8b4d1ef..340a28d0e334 100644
--- a/dev-ruby/rex-exploitation/Manifest
+++ b/dev-ruby/rex-exploitation/Manifest
@@ -1,3 +1,5 @@
DIST rex-exploitation-0.1.19.gem 79360 BLAKE2B 47043054ee9d08775c67d54b31861ad3a454a487bdc47beb135942e267040de7611308c62a23cbf853d190fb8f88c52998dfe3b24f66a698e76e273b6a69d822 SHA512 244de5259e3f4f645df09d1843c34d9ea4f9ea56ba22498495792f192b79a0451810f5c7e73516da5a455c27e61b66f8ccfbc485372946fcedd179b75ff9b31e
+DIST rex-exploitation-0.1.20.gem 79360 BLAKE2B 59dea65582647444e21cc1b0ae744c857b3007b8215c81244d37c6f3d8abcb1ef1b1d01428f306b4c5f6fdd1b3db0326de3c50fa38fa50505b4de9c05ba518e1 SHA512 e1df4ffde57ab40bf4b2492370d44bf064f39f657c7a8140416f51560a0be9b31ef95b1bdadaae6f6ec75c86e0978b41112a18caa1f69262c67945d3529f9990
EBUILD rex-exploitation-0.1.19.ebuild 623 BLAKE2B db040a15cc88f665e28bcbe3aa61050ea013d58ae4b250e8a129e9bfcea5dc8b04cfde68573c5c9c6d9e2617751f28cb02ebb61e08b862ad46b46842c04cf882 SHA512 5e1e3c631fbca630730438e837696965a21f1c6a1ef49fa311752fe3361c47cc769732d73857a7e8f0913c2700b5d2e51c11fa285241b10928cc48cc9adf307e
+EBUILD rex-exploitation-0.1.20.ebuild 620 BLAKE2B fb55ed0b54719e26fdb472d4482175a694096f4ec48e04a01f9167fb4ce4b04aa9da3ba52fbe137bbb5ec95e74d9b467c49795fd17e53b3797588c764010dab1 SHA512 eb708f52068f838eb0d0d04de566cf617b47164d2936bf48d957d79191f57c621e00100c3345773fd02e6f95aa95cb7890d7202420319caaca447c73d7c8bc25
MISC metadata.xml 405 BLAKE2B f814e2256b6d217a3ee4353eb07d5f5eda723cf7bcf06504ba34df7345584e1feb4320d445b5e5a2c91e9e86948291db47c06c60864954735181ef5bb790c993 SHA512 3af40e7e532b1d0c141aa419cdd5f10dc151c3406e90bc56e7e281a78e8fca7e8204213d6e0ffc6ed74ae4d0ca6a9bc79c5c4760be0406b0d89694d0299d5c85
diff --git a/dev-ruby/rex-exploitation/rex-exploitation-0.1.20.ebuild b/dev-ruby/rex-exploitation/rex-exploitation-0.1.20.ebuild
new file mode 100644
index 000000000000..e00da4173939
--- /dev/null
+++ b/dev-ruby/rex-exploitation/rex-exploitation-0.1.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="various helper mechanisms for creating exploits"
+HOMEPAGE="https://rubygems.org/gems/rex-exploitation"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/jsobfu:*
+ dev-ruby/metasm:*
+ dev-ruby/rex-arch
+ dev-ruby/rex-encoder
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}