summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-bin_tools/rex-bin_tools-0.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-ruby/rex-bin_tools/rex-bin_tools-0.1.6.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-ruby/rex-bin_tools/rex-bin_tools-0.1.6.ebuild')
-rw-r--r--dev-ruby/rex-bin_tools/rex-bin_tools-0.1.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rex-bin_tools/rex-bin_tools-0.1.6.ebuild b/dev-ruby/rex-bin_tools/rex-bin_tools-0.1.6.ebuild
new file mode 100644
index 000000000000..1ac91d731a63
--- /dev/null
+++ b/dev-ruby/rex-bin_tools/rex-bin_tools-0.1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="suite of tools for analyzing executables to find specific chunks of code"
+HOMEPAGE="https://rubygems.org/gems/rex-bin_tools"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rex-arch
+ dev-ruby/metasm:*
+ dev-ruby/rex-core
+ dev-ruby/rex-struct2
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}