summaryrefslogtreecommitdiff
path: root/dev-ruby/redcloth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
commitd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (patch)
tree2a3ee43f080d1d0086964de8c29ccf1021fdfda7 /dev-ruby/redcloth
parentea31ad0ed5501d0bf92267c35beaf06ac016bad2 (diff)
gentoo resync : 15.05.2018
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/Manifest2
-rw-r--r--dev-ruby/redcloth/files/redcloth-4.3.2-load-documents.patch30
-rw-r--r--dev-ruby/redcloth/redcloth-4.3.2-r1.ebuild59
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-ruby/redcloth/Manifest b/dev-ruby/redcloth/Manifest
index e38ad798b5bc..8638cc09b27a 100644
--- a/dev-ruby/redcloth/Manifest
+++ b/dev-ruby/redcloth/Manifest
@@ -1,3 +1,5 @@
+AUX redcloth-4.3.2-load-documents.patch 988 BLAKE2B 75e2a385abaf14caef523ae418e87b000900c93d3afe4491300335dd9d5a26fef28a34b3318fada0625e91cafba42a82fb05a2d8acfd6c5afcff4e8ac491890f SHA512 cce18ba0c30d6820020d71dd032d1b193976eaa103ca7bb294a7b1cfb0e61b82aa31e0d8bd8b8d9305e8c087a4109563897a7cd77ec9c020b453c8dc97d48003
DIST RedCloth-4.3.2.tar.gz 91880 BLAKE2B 0feac1ec59e23fcff39e2fdf9beff896be7949764e53a5a834c5f4e7d18813dc59bf354103d4fab82a709341a0f1b6919bbd3a463fd601564888672dbe73d343 SHA512 377fef21e646beb1658a4b8b8d0228e9730c6c8f33075a14137afcf80e8d37501ede8c05b720d0dfb36a680017f4dedd01565fe9b326ae06ead77afee6f122ca
+EBUILD redcloth-4.3.2-r1.ebuild 1528 BLAKE2B 3c545a008966be3b5257d4516f3e3dec581a32d7206f1e07c2880e7e63fcd4abc328ccda7a5b9a9444b31bc41558c93a8c0c8fe4bcaef3a9dec5945e0c926822 SHA512 3dac983b3643e10d1f44d6e34ffd82deecb3a8da5715f08f64e9a7ea21c9b0ff6dafab6ad82d7ec1eb47b55cba58651b3d0be6d62ebc1c87fb7790439e6aa5b7
EBUILD redcloth-4.3.2.ebuild 1492 BLAKE2B 54b4298a1cbc53654fc2267980862178f460cc8dae333a44f50ab3cfa260ca7771960f8250672c3265987c17ef801f5b3bca07ef4a2acd74ddf63d300fd5f4d3 SHA512 e0f9cec61de18d2276ed908f6fe275adaa373dc0ed57e1f3b18f89e04a773c2782231c0021c01616ed8f8383d768a1baaa4779d3e01ce98af3f20692c9709291
MISC metadata.xml 342 BLAKE2B f28d0e6234cfbeb3d398315b38e8dcc614b32aed150b047e61e7d99b2f6083abbabc36515de2cd2aa4d451dd3372dfc15018c1d8ad02cf64ff8e87b147a441da SHA512 7a6f73a77cda62ea21a2d2fdfcf0bf848ffdd90e7272e0b06aef67a8147e5a6ae14e871d216750ce20d12e18823d3e3d36e60a99972019fde7195a2350480791
diff --git a/dev-ruby/redcloth/files/redcloth-4.3.2-load-documents.patch b/dev-ruby/redcloth/files/redcloth-4.3.2-load-documents.patch
new file mode 100644
index 000000000000..f390afd58268
--- /dev/null
+++ b/dev-ruby/redcloth/files/redcloth-4.3.2-load-documents.patch
@@ -0,0 +1,30 @@
+From 00b55ace17ed408b1b6129e1ba6c90fd4f0a6d2c Mon Sep 17 00:00:00 2001
+From: Matijs van Zuijlen <matijs@matijs.net>
+Date: Tue, 29 Aug 2017 08:08:36 +0200
+Subject: [PATCH] Replace deprecated YAML.load_documents
+
+The .load_documents method is deprecated and seems to have been removed
+entirely in the upcoming Ruby 2.5.
+---
+ spec/spec_helper.rb | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
+index af6279a..74a5cae 100644
+--- a/spec/spec_helper.rb
++++ b/spec/spec_helper.rb
+@@ -26,11 +26,11 @@ def fixtures
+ Dir[File.join(File.dirname(__FILE__), *%w[fixtures *.yml])].each do |testfile|
+ testgroup = File.basename(testfile, '.yml')
+ num = 0
+- YAML::load_documents(File.open(testfile)) do |doc|
++ YAML::load_stream(File.open(testfile)) do |doc|
+ name = doc['name'] || num
+ @fixtures["#{testgroup} #{name}"] = doc
+ num += 1
+ end
+ end
+ @fixtures
+-end
+\ No newline at end of file
++end
diff --git a/dev-ruby/redcloth/redcloth-4.3.2-r1.ebuild b/dev-ruby/redcloth/redcloth-4.3.2-r1.ebuild
new file mode 100644
index 000000000000..06d1e166eb64
--- /dev/null
+++ b/dev-ruby/redcloth/redcloth-4.3.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_NAME="RedCloth"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG"
+
+RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A module for using Textile in Ruby"
+HOMEPAGE="http://redcloth.org/"
+
+GITHUB_USER=jgarber
+SRC_URI="https://github.com/${GITHUB_USER}/redcloth/archive/v${PV}.tar.gz -> ${RUBY_FAKEGEM_NAME}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND+=" =dev-util/ragel-6*"
+
+PATCHES=( "${FILESDIR}/${P}-load-documents.patch" )
+
+ruby_add_bdepend "
+ >=dev-ruby/rake-0.8.7
+ >=dev-ruby/rake-compiler-0.7.1
+ test? ( >=dev-ruby/diff-lcs-1.1.2 )"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+
+ # Export the VERBOSE variable to avoid remapping of stdout and
+ # stderr, and that breaks because of bad interactions between
+ # echoe, Ruby and Gentoo.
+ export VERBOSE=1
+}
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile ${PN}.gemspec || die
+ rm -f tasks/{release,rspec,rvm}.rake || die
+}
+
+each_ruby_compile() {
+ # We cannot run this manually easily, because Ragel re-generation
+ # is a mess
+ ${RUBY} -S rake compile || die "rake compile failed"
+}