summaryrefslogtreecommitdiff
path: root/dev-ruby/rdtool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/rdtool
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/rdtool')
-rw-r--r--dev-ruby/rdtool/Manifest1
-rw-r--r--dev-ruby/rdtool/rdtool-0.6.38-r3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/rdtool/Manifest b/dev-ruby/rdtool/Manifest
index cb81f211180a..e84342a2d58b 100644
--- a/dev-ruby/rdtool/Manifest
+++ b/dev-ruby/rdtool/Manifest
@@ -1,4 +1,5 @@
AUX 50rdtool-gentoo.el 174 BLAKE2B 9480cb7873a3f12db0cfff40adb1bd18a5f5fb8c8249c24767631aa9f0f341237fb8c9ccd3cc720ddbe02c63b0d7846127706f7a25def3ca23e71716099e538c SHA512 77e893e6c9660b8a6cb2b8e7d1134867c4e9d38acbf11db4ee948f288b69dfe3a938ab0d37bca7b4b9da2f6ca27fa27e2d9c17629ef3c0d49797f65c036c472f
DIST rdtool-0.6.38.gem 115712 BLAKE2B 037575dd890512ad1f88a4a04532b6c2b8ca6d5245cccaf7ab1b7f51fad971e449bf280bf5ffdb295f212d56add4e817fff5494b0bba011229cf54d2ed74e1aa SHA512 958e9066a8b3610eb1a78069e615c5bd672aa56b3b45669604b35cd094bb8ddc549d8f373d1ee53864c27a0aa7ee038101b3256c56b3b8ffe618f75a1a939bcd
EBUILD rdtool-0.6.38-r2.ebuild 800 BLAKE2B 4168f168c254453e044224c04850b2b525d8c9b1dba48816c096b060f18927a6e310d5836bdd0d3521b9e7f76222360c806ea27e9bf28f0fc7a629939166df4c SHA512 7d1aa21ac3f4bffb0f7bbe75308f760a973b18071ac18697dd26b67cd349ef57a4b8fddefbe96b26bf4e687d53dc6fe39297966952c8180ef085e9c2452e7ee0
+EBUILD rdtool-0.6.38-r3.ebuild 800 BLAKE2B 13751a52cb55a1c5e1cf2cd3f3cd0fa3089a77f1ddc47b35a0f1dc5136dc6dd87e12e1d544419f99ee7e56733027c9419373f2734a228a951ccfeb0fe9481956 SHA512 a26bb2254f47b94d864cf906725390ac6ada054fcbf51e77c030d141c496dd628357622044aad5adb6c5489e52e79ac243c20be9910fbc673fb6095ef3e6e170
MISC metadata.xml 341 BLAKE2B c7869bdbb270ce39e061039cca7efd99b85ecfad0c14daf5f7dd236e8d489d23776b0f606c78a0a5608e7902976428612aca2c3e92bca7ad2b04805d6a3c80ad SHA512 acbcaeed327c0b86b7c46a3cc0f63da5956ae66d5ba356a8bdb3d2b96589c84c95b3961ba7663991dc82ff1861903b05ea004b314de6e4b651e32a7502380a9d
diff --git a/dev-ruby/rdtool/rdtool-0.6.38-r3.ebuild b/dev-ruby/rdtool/rdtool-0.6.38-r3.ebuild
new file mode 100644
index 000000000000..6edcdda0fe91
--- /dev/null
+++ b/dev-ruby/rdtool/rdtool-0.6.38-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.*"
+
+inherit elisp-common ruby-fakegem
+
+DESCRIPTION="A multipurpose documentation format for Ruby"
+HOMEPAGE="https://github.com/uwabami/rdtool"
+
+LICENSE="Ruby GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="emacs"
+
+RDEPEND="${RDEPEND} emacs? ( >=app-editors/emacs-23.1:* )"
+
+SITEFILE=50${PN}-gentoo.el
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use emacs ; then
+ elisp-install ${PN} utils/rd-mode.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}