summaryrefslogtreecommitdiff
path: root/dev-ruby/rdiscount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/rdiscount
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/Manifest5
-rw-r--r--dev-ruby/rdiscount/metadata.xml11
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.1.8.ebuild47
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.2.0.1.ebuild47
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-ruby/rdiscount/Manifest b/dev-ruby/rdiscount/Manifest
new file mode 100644
index 000000000000..4ea3803b07a0
--- /dev/null
+++ b/dev-ruby/rdiscount/Manifest
@@ -0,0 +1,5 @@
+DIST rdiscount-2.1.8.gem 67072 BLAKE2B c5295e9e78763f65815aaeaad01e6a5f5cafe2df66466d2f0fc31930db96403819ab3b27883b8a94a50f0d470059014fc39a5e24f62f8ec22cbe88f9bfabcdeb SHA512 a5d674a02514cb37d7e3a73bcc9131b434f624115e03f1ef5cef3ec4a378bb961966ef20daf93279b40715dcd19a0b79ccc43405fbe4523ac298f3255dca83f3
+DIST rdiscount-2.2.0.1.gem 68096 BLAKE2B 71ea7010116739e8c61aab91c2cc4a86cf679b4ae10221135c0bad854822a9a81969e927ef898c0ebf753811205ad98258c4e7c4b16f9e18a81bb01137a79fc9 SHA512 81a477782b9829ac5e68ab390ef00b7f470bb4bd84e86ce28dd9abbb71aab6fd17b67416078dd7d4e0fc7e0c8eb78250b7a71a2f24d2bd236e861cb445f9feb6
+EBUILD rdiscount-2.1.8.ebuild 1084 BLAKE2B f0bf0f2409c72156c4a05bb00eebd35727069273d9aab4b4b904294513f769cb8e41f0021783f17a4fb9cca4ed56a78cdc11662110064a0811da44ff48f4146a SHA512 dd39e67d04e9a243960d83fb2eaddb68407abead11d22ff56246232374a5dbcb31a955689d93e681c7bad43f3b4b40c0fc103193d3c205098393f547d17f3c44
+EBUILD rdiscount-2.2.0.1.ebuild 1105 BLAKE2B 30090e280289d0b6f2398d8f798d12677e2b0243f183b575765492b753b7273f1acc195f524abc0b5a9903f3df611f2b064ca9c5aecd651425bde1240e34a2f1 SHA512 1dbf6e389e201b5a4d382c0b33a91d63b83f41f907c4d9d1cbd5528796bed146e938976e2f42d53b840d11b3c0549ef33cb1925175378218a5deac7eb2084fcd
+MISC metadata.xml 344 BLAKE2B 4afa4c43c02006cc29edbfd9c7792c42aec4aff05203b57a9e727ec6333f3f55c13b8f197f915f8a632d9deb888f5e00f3992fa8df48d7f0969206927a342d0b SHA512 4d2e68c0284b778089ddae07ad5026c296d997afc771a5b3b994464691ac794dee27f1f7bbdbdbe2037565be70d2bc480480a7b93c867dc100dca228b09b7aec
diff --git a/dev-ruby/rdiscount/metadata.xml b/dev-ruby/rdiscount/metadata.xml
new file mode 100644
index 000000000000..3ae80c3decbd
--- /dev/null
+++ b/dev-ruby/rdiscount/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rtomayko/rdiscount</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rdiscount/rdiscount-2.1.8.ebuild b/dev-ruby/rdiscount/rdiscount-2.1.8.ebuild
new file mode 100644
index 000000000000..0454d99cbc0d
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.1.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x64-macos"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext || die
+ cp ext/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}
diff --git a/dev-ruby/rdiscount/rdiscount-2.2.0.1.ebuild b/dev-ruby/rdiscount/rdiscount-2.2.0.1.ebuild
new file mode 100644
index 000000000000..16e8b75736f6
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.2.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext || die
+ cp ext/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}