summaryrefslogtreecommitdiff
path: root/dev-ruby/rdiscount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ruby/rdiscount
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/Manifest2
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.2.0.2.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/rdiscount/Manifest b/dev-ruby/rdiscount/Manifest
index cb76768d3653..0a19c7293b10 100644
--- a/dev-ruby/rdiscount/Manifest
+++ b/dev-ruby/rdiscount/Manifest
@@ -1,3 +1,5 @@
DIST rdiscount-2.2.0.1.gem 68096 BLAKE2B 71ea7010116739e8c61aab91c2cc4a86cf679b4ae10221135c0bad854822a9a81969e927ef898c0ebf753811205ad98258c4e7c4b16f9e18a81bb01137a79fc9 SHA512 81a477782b9829ac5e68ab390ef00b7f470bb4bd84e86ce28dd9abbb71aab6fd17b67416078dd7d4e0fc7e0c8eb78250b7a71a2f24d2bd236e861cb445f9feb6
+DIST rdiscount-2.2.0.2.gem 68096 BLAKE2B 91f67643103a46f3fc95f80191a85ce4c89bba6a83f7ed5542cc9ec1671628c6ac0543b206d87e2ffc469dc83139e5669ee7eb6713eba4116db19c071a15f402 SHA512 97a0fabb77238173f101298e4b4b6d4728b9e15cb7d3f14e7d1d978c44ab92dd89c2e02d0c15c0fa70a836eb54abca06b0027e26e5d87540bfe145c8527be3f7
EBUILD rdiscount-2.2.0.1.ebuild 1104 BLAKE2B 371e3a605e9c4b68be5ab0a8a1fdfeea50f40a5e3345fb9f773bc0fd210accdb7550848d03d311490c82fc420efc5d5f8724b19d1eb2f9465e8cac9ee4414ee5 SHA512 b4e0818c4161d198b01c0d380e1ba05fc493ee0b71811b9413cc267e7636c69b646d2dbed9e4f3c220e1a0213df3da7e4102dd86e18082d5f3db17bd7ecb154d
+EBUILD rdiscount-2.2.0.2.ebuild 1104 BLAKE2B e978ef2fbd6c44ccae3ae10e924add47cfc1ebd37416c82bd727d7d9a833667d593b11883923fb1c6c7983556967bd3d2e1e06397c99d4d160ec3c131ea35541 SHA512 564ea44ff5d5dc3def1f111caaeb1e7aac5d52709ee56990eaf85267185106b4fc47075b4eff454777775ef7ae248150e399d56174908604ec5bc6e6e19505fb
MISC metadata.xml 344 BLAKE2B 4afa4c43c02006cc29edbfd9c7792c42aec4aff05203b57a9e727ec6333f3f55c13b8f197f915f8a632d9deb888f5e00f3992fa8df48d7f0969206927a342d0b SHA512 4d2e68c0284b778089ddae07ad5026c296d997afc771a5b3b994464691ac794dee27f1f7bbdbdbe2037565be70d2bc480480a7b93c867dc100dca228b09b7aec
diff --git a/dev-ruby/rdiscount/rdiscount-2.2.0.2.ebuild b/dev-ruby/rdiscount/rdiscount-2.2.0.2.ebuild
new file mode 100644
index 000000000000..97b12d1ab7a8
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.2.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}