summaryrefslogtreecommitdiff
path: root/dev-ruby/rbst
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/rbst
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rbst')
-rw-r--r--dev-ruby/rbst/Manifest3
-rw-r--r--dev-ruby/rbst/metadata.xml8
-rw-r--r--dev-ruby/rbst/rbst-0.5.1.ebuild48
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/rbst/Manifest b/dev-ruby/rbst/Manifest
new file mode 100644
index 000000000000..41da48d040f2
--- /dev/null
+++ b/dev-ruby/rbst/Manifest
@@ -0,0 +1,3 @@
+DIST rbst-0.5.1.tar.gz 14039 BLAKE2B 7399e92f98c650842464ea9240775ad776ec8d574c578d8da764778bbe8050be429e2521df82b3b04a0bf9cd18bef4f114890d54ef8d6f34c797f0f2f2e35bc2 SHA512 a7fffc1ccf495c1858d6d9fadd38a4d6a2c27a2da8eda8dad038f4ab881f4521223a35f97d4018d25b32c2621132a623040ba930494b36e1385356ecb87fecdc
+EBUILD rbst-0.5.1.ebuild 1130 BLAKE2B b515b1b6b55bb3c92f9f96f8d90472005de9c04527b1e0d83bc1b69f318e77c1f70ed884588ea146738026631bdb05d287aac4b3c9a62af0460cbe3d831d8ea8 SHA512 15a0f5f20b8ad16f593317f8e43ceaa8e0d9d06fe383a6000a8ff7b41a622bb5fb4c2ef3925064116a4109e497e1f2a8d3b11ec295a936396cadf533931376b1
+MISC metadata.xml 247 BLAKE2B 1750cec57189e711ca5eba89a78e1d317f0839fa53564fbd39b4e955c28d98f4ae04caf9069afc20a18536cdc92b30fe7b15eb086767c742bad07d9980cfd24b SHA512 d6e2ea8a9d74791bcbf3d6311a66bafc20b8f4db3a576d9a8d54b86d7afb231122b8d87f71f3f46360980adf8d815c633b6d5041f9a30fc8656e8fb66057a282
diff --git a/dev-ruby/rbst/metadata.xml b/dev-ruby/rbst/metadata.xml
new file mode 100644
index 000000000000..0319eec4c8be
--- /dev/null
+++ b/dev-ruby/rbst/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/rbst/rbst-0.5.1.ebuild b/dev-ruby/rbst/rbst-0.5.1.ebuild
new file mode 100644
index 000000000000..47d5cfc57ee1
--- /dev/null
+++ b/dev-ruby/rbst/rbst-0.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_NAME="RbST"
+RUBY_FAKEGEM_GEMSPEC="RbST.gemspec"
+
+inherit python-single-r1 ruby-fakegem
+
+DESCRIPTION="A simple Ruby wrapper for processing rST via docutils"
+HOMEPAGE="https://github.com/alphabetum/rbst"
+SRC_URI="https://github.com/alphabetum/rbst/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/docutils"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-ruby/mocha-1.1.0:1.0
+ >=dev-ruby/shoulda-3.5.0:3
+ >=dev-ruby/test-unit-3.0.9:2
+ )"
+
+# Tests are pretty much useless as they depend on very specific output
+# from an unknown docutils version.
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ ruby-ng_pkg_setup
+}
+
+all_ruby_prepare() {
+ # do not use bundler
+ sed -i -e '/bundler/,/end/d' \
+ Rakefile test/helper.rb || die
+
+ # force our python version
+ sed -i -e "s:\(python_path=\"\)python:\1${EPYTHON}:" lib/rbst.rb || die
+ python_fix_shebang lib/rst2parts
+}