summaryrefslogtreecommitdiff
path: root/dev-ruby/rbst
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-10 17:08:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-10 17:08:48 +0100
commit5b5704b62a0f04d93fd58986b426a31352fe2fd5 (patch)
tree0034259fd845f22388e30e34a06f2fe12537cd30 /dev-ruby/rbst
parent77ffa9fa127c2f664cbb6aba05848662a904f2ff (diff)
gentoo resync : 10.10.2017
Diffstat (limited to 'dev-ruby/rbst')
-rw-r--r--dev-ruby/rbst/Manifest3
-rw-r--r--dev-ruby/rbst/metadata.xml8
-rw-r--r--dev-ruby/rbst/rbst-0.5.1.ebuild48
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/rbst/Manifest b/dev-ruby/rbst/Manifest
new file mode 100644
index 000000000000..e09bb61d5644
--- /dev/null
+++ b/dev-ruby/rbst/Manifest
@@ -0,0 +1,3 @@
+DIST rbst-0.5.1.tar.gz 14039 SHA256 95d8ba25bde6c16e0565f480b377c9377168af889c32a90b0a55dd46cf74f547 SHA512 a7fffc1ccf495c1858d6d9fadd38a4d6a2c27a2da8eda8dad038f4ab881f4521223a35f97d4018d25b32c2621132a623040ba930494b36e1385356ecb87fecdc WHIRLPOOL d31d1742f9e998388da6d0f763ed558596b5a84cc1ae66ae296d45a26add0fefefb92b571d32cede481d28a2a3ac8eabf91cd1dc9bcc907d20bf9b9b604bd994
+EBUILD rbst-0.5.1.ebuild 1130 SHA256 9bfe11a65adead265556795b4b0e829fa5180d8db446f565ce9414173b6eb74a SHA512 15a0f5f20b8ad16f593317f8e43ceaa8e0d9d06fe383a6000a8ff7b41a622bb5fb4c2ef3925064116a4109e497e1f2a8d3b11ec295a936396cadf533931376b1 WHIRLPOOL 1ba75508af69e5d6af571325fb3698307802b1780b6864d06e97be7c110a30aebc63c6c7e539751e61d88539ad0d514197ee0dafb7f41cd44fb0f609b67b3c3b
+MISC metadata.xml 247 SHA256 34d6ed4186bad4ac57e0b4c08b657b14e28852a83c4ccf4d8a62f7829063b1cf SHA512 d6e2ea8a9d74791bcbf3d6311a66bafc20b8f4db3a576d9a8d54b86d7afb231122b8d87f71f3f46360980adf8d815c633b6d5041f9a30fc8656e8fb66057a282 WHIRLPOOL fbd18b3e6e3d777e8d78e91b8d32c5e357fd2a1c754d2c9add4622be682521e59556f466cba397d913f0e63265202744ceaf76dc7823be0a172a9bf4da6a2579
diff --git a/dev-ruby/rbst/metadata.xml b/dev-ruby/rbst/metadata.xml
new file mode 100644
index 000000000000..0319eec4c8be
--- /dev/null
+++ b/dev-ruby/rbst/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/rbst/rbst-0.5.1.ebuild b/dev-ruby/rbst/rbst-0.5.1.ebuild
new file mode 100644
index 000000000000..47d5cfc57ee1
--- /dev/null
+++ b/dev-ruby/rbst/rbst-0.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_NAME="RbST"
+RUBY_FAKEGEM_GEMSPEC="RbST.gemspec"
+
+inherit python-single-r1 ruby-fakegem
+
+DESCRIPTION="A simple Ruby wrapper for processing rST via docutils"
+HOMEPAGE="https://github.com/alphabetum/rbst"
+SRC_URI="https://github.com/alphabetum/rbst/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/docutils"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-ruby/mocha-1.1.0:1.0
+ >=dev-ruby/shoulda-3.5.0:3
+ >=dev-ruby/test-unit-3.0.9:2
+ )"
+
+# Tests are pretty much useless as they depend on very specific output
+# from an unknown docutils version.
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ ruby-ng_pkg_setup
+}
+
+all_ruby_prepare() {
+ # do not use bundler
+ sed -i -e '/bundler/,/end/d' \
+ Rakefile test/helper.rb || die
+
+ # force our python version
+ sed -i -e "s:\(python_path=\"\)python:\1${EPYTHON}:" lib/rbst.rb || die
+ python_fix_shebang lib/rst2parts
+}