summaryrefslogtreecommitdiff
path: root/dev-ruby/rbnacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
commit483d7c056fba15727fe24545f93627a1d1e1e2eb (patch)
tree80d144b60f8e1dc0d14c15cb3e5950da12c80074 /dev-ruby/rbnacl
parent8796aaedb3257bbe4d80b0033408b2210b2259d6 (diff)
gentoo auto-resync : 18:10:2024 - 04:04:23
Diffstat (limited to 'dev-ruby/rbnacl')
-rw-r--r--dev-ruby/rbnacl/Manifest2
-rw-r--r--dev-ruby/rbnacl/rbnacl-7.1.2.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/rbnacl/Manifest b/dev-ruby/rbnacl/Manifest
index 7bd64ed42f2d..42543e9ff503 100644
--- a/dev-ruby/rbnacl/Manifest
+++ b/dev-ruby/rbnacl/Manifest
@@ -1,3 +1,5 @@
DIST rbnacl-7.1.1.gem 226304 BLAKE2B 4c7c356cc3414c1b49302ff16af701bffbeaaa18b49bcdb4c9d0c10fe2e1f693e7917f8031c90d5c4362d95ffe5a8d471a48476788f64f97092adbcdce0d9f72 SHA512 da7e406bd2b5112e51d2c15cab35d955b65091ed745fbd027750eaca8ff1d11d982c82f497fc15b9ee9aa6536dbd21ff9ac285bb2a2d1fb39c3374fd0f3dca5a
+DIST rbnacl-7.1.2.tar.gz 93911 BLAKE2B 1a93fcec94464eb7109684faaee4a9f3206eb7c2d9f505cd95920431a2422d9d291104469cd3a326f54ffffb1e9bfdfcd924ff7b4777dad70071ff3f61500410 SHA512 f44493158f9bc9f6075d046d9dd6505bc8ca65cbc3e8685b8821540e6989ef0a798a2af9eebd648e80321fc6fdd593b81133696d0dadfdf7c43bd4fa32557633
EBUILD rbnacl-7.1.1-r1.ebuild 709 BLAKE2B 42a21db7d1d99b726fe9456f8cee3eaae867dcab9c5f181efdfe5e3076373f2b4fa33de791daab1131f529e4f46037a314024937e85a774bd9a4b483ddd9e429 SHA512 8ebbf1ac93de528545396f553c0882833c48fb9d25ee015fc6ff6ed87ab987ff96cb2d1af31b26aa6f524902f922826a92c2dbdb21826f265b99e3073d0d46c2
+EBUILD rbnacl-7.1.2.ebuild 956 BLAKE2B 29b0f45813d27c5982f4e3844d06aaa7414ed8fa871350eae998f98372cbc0a4dbb5189f8f3f0fabe39057adfef8020328b96e3b1f88f97a160a776f3d492112 SHA512 7b694572719988cd29207ab603d5c0dde7a704159f687f1b5cc11544f3f4d9f2566f0d982e454c7888055788502a90fc90350acf3df6b2e2b984b064185d820e
MISC metadata.xml 344 BLAKE2B 56ac8f1ae1e1cf2cef2d8f7920557552a2941070b581ddee21e63c7f5192ebadc05e2150bdedba282c9b3f4e4f0398e57b59c522b35656e2d5ab17ff5f0feeee SHA512 590ae6a645898f3d78add701dc98a40fd54a571b837d23f257ed206e73bfa3859eb089f7d3560d7c7fb3aec00eecbda24cc4ca6b7a1e0804b3b4ba75911f3b34
diff --git a/dev-ruby/rbnacl/rbnacl-7.1.2.ebuild b/dev-ruby/rbnacl/rbnacl-7.1.2.ebuild
new file mode 100644
index 000000000000..3f7aa8faed5e
--- /dev/null
+++ b/dev-ruby/rbnacl/rbnacl-7.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_GEMSPEC="rbnacl.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a high-level toolkit for building cryptographic systems and protocols"
+HOMEPAGE="https://github.com/RubyCrypto/rbnacl"
+SRC_URI="https://github.com/RubyCrypto/rbnacl/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="6"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=" dev-libs/libsodium"
+DEPEND=" test? ( dev-libs/libsodium )"
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/git ls-files/find * -print/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/bundler/ s:^:#:' \
+ -e 's:rbnacl/libsodium:rbnacl:' spec/spec_helper.rb || die
+}