summaryrefslogtreecommitdiff
path: root/dev-ruby/rbnacl/rbnacl-7.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:56:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:56:30 +0100
commit948d557b4a61dc14722668b6b11a4cf3cee07b01 (patch)
treeb28b6cb077ae6b2457e30d49028fc978d8e2b59b /dev-ruby/rbnacl/rbnacl-7.1.0.ebuild
parente3cf2c86fca1750343c1885311f857f185ee4f2d (diff)
gentoo resync : 13.09.2019
Diffstat (limited to 'dev-ruby/rbnacl/rbnacl-7.1.0.ebuild')
-rw-r--r--dev-ruby/rbnacl/rbnacl-7.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rbnacl/rbnacl-7.1.0.ebuild b/dev-ruby/rbnacl/rbnacl-7.1.0.ebuild
new file mode 100644
index 000000000000..e947ec005c6e
--- /dev/null
+++ b/dev-ruby/rbnacl/rbnacl-7.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a high-level toolkit for building cryptographic systems and protocols"
+HOMEPAGE="https://github.com/cryptosphere/rbnacl"
+
+LICENSE="MIT"
+SLOT="6"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-libs/libsodium"
+DEPEND+=" test? ( dev-libs/libsodium )"
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/bundler/ s:^:#:' \
+ -e 's:rbnacl/libsodium:rbnacl:' spec/spec_helper.rb
+}