summaryrefslogtreecommitdiff
path: root/dev-ruby/rb-inotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /dev-ruby/rb-inotify
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'dev-ruby/rb-inotify')
-rw-r--r--dev-ruby/rb-inotify/Manifest1
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/Manifest b/dev-ruby/rb-inotify/Manifest
index efbe3d1921c1..53361da1aa79 100644
--- a/dev-ruby/rb-inotify/Manifest
+++ b/dev-ruby/rb-inotify/Manifest
@@ -1,3 +1,4 @@
DIST rb-inotify-0.9.10.gem 14848 BLAKE2B 35eb00dfe1e7e76fddda080499275c053e82431af520170362354984cb2af3c90e3ba803ef82fe50f1451d3fdb0ddb7ef9c1dc648836403a6865396987d6d9c2 SHA512 ee1aecfebea11655450776013d8d2fa3fb2af784285db3c32b5a452241f9cd48a8f9a10cb2f1ff96b191c0dcd43ec4f78e8a363447abf97a8cd4ccb778de4889
+EBUILD rb-inotify-0.9.10-r1.ebuild 962 BLAKE2B f3af41066b3479cf6fbea4cd76a8afc60f5406bb27ab65278bdf8bce20a9baa904a20443b57c0026371e95241c1af55be887a1f9901fb0320cb4b061f5adaac9 SHA512 2548a6d1d7dc72c286fcda9bfb311a90209fbe254a97b096611b18cedbc7da2f7bd51ef6db837a16ee84b02180421a94e5b060cb62d144f7e28ed301cd1c057d
EBUILD rb-inotify-0.9.10.ebuild 967 BLAKE2B 869f4bf9bd834357a60a38fd9089683a4156bbcb9373faaee043ffb399256347bbec07a9363d2540834a37e8d27235cbb49c464449c29fd9d7f40733b8f6c9fc SHA512 835e3be6628017ba94c7a22fda09429a4217cabd1b02550b4c28ad6f4d554f16bb18ab4a3a75be4a0267ea2473e8c4ec28b93050f8e41bcbd7c45fb1e254178b
MISC metadata.xml 341 BLAKE2B 9b7d043d113a1bfd0bb07588615f04762e5d4334763055dcf818969aa98c543c19b1e1005d3f8e0ad5d6c0dfed342b3ee8f2bfd9a49eb133b34f5cafd6f7f91d SHA512 0449efdf61caad416c9b68e1b5de20c46d29a8961f462dd7f1971e3723b8b0b3567507cc99cfeb2151e0c8c14caa28947dc23906281b20771251b3b47823b4a4
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..b516935037a8
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.9.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}