summaryrefslogtreecommitdiff
path: root/dev-ruby/rb-gsl/rb-gsl-2.1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/rb-gsl/rb-gsl-2.1.0.2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rb-gsl/rb-gsl-2.1.0.2.ebuild')
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-2.1.0.2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/rb-gsl/rb-gsl-2.1.0.2.ebuild b/dev-ruby/rb-gsl/rb-gsl-2.1.0.2.ebuild
deleted file mode 100644
index 0408c68266b6..000000000000
--- a/dev-ruby/rb-gsl/rb-gsl-2.1.0.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_NAME="gsl"
-inherit ruby-fakegem multilib
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md"
-
-DESCRIPTION="Ruby interface to GNU Scientific Library"
-HOMEPAGE="https://github.com/SciRuby/rb-gsl"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-DEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
-RDEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
-
-RUBY_S="${PN}-${P}"
-
-ruby_add_bdepend "dev-ruby/narray"
-ruby_add_rdepend "dev-ruby/narray"
-
-all_ruby_prepare() {
- sed -i -e '/LOCAL_LIBS/ s: -l: -L#{path.gsub("ext", "lib")} -l:' ext/gsl_native/extconf.rb || die
- # nmatrix only tests
- rm -r test/gsl/nmatrix_tests || die
-}
-
-each_ruby_configure() {
- NARRAY=1 ${RUBY} -Cext/gsl_native extconf.rb || die
- sed -i -e 's:-Wl,--no-undefined::' ext/gsl_native/Makefile || die
-}
-
-each_ruby_compile() {
- NARRAY=1 emake -Cext/gsl_native V=1
- cp ext/gsl_native/*$(get_modname) lib/ || die
-}
-
-each_ruby_test() {
- NARRAY=1 ${RUBY} -Ilib:test:. -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
-}