summaryrefslogtreecommitdiff
path: root/dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild')
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild b/dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild
new file mode 100644
index 000000000000..5fc4e9e1c9d9
--- /dev/null
+++ b/dev-ruby/rb-gsl/rb-gsl-2.1.0.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_NAME="gsl"
+inherit ruby-fakegem multilib
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/gsl_native/extconf.rb)
+
+DESCRIPTION="Ruby interface to GNU Scientific Library"
+HOMEPAGE="https://github.com/SciRuby/rb-gsl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="doc"
+
+DEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
+RDEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
+
+RUBY_S="${PN}-${P}"
+
+ruby_add_bdepend "dev-ruby/narray"
+ruby_add_rdepend "dev-ruby/narray"
+
+all_ruby_prepare() {
+ sed -i -e '/LOCAL_LIBS/ s: -l: -L#{path.gsub("ext", "lib")} -l:' ext/gsl_native/extconf.rb || die
+ # nmatrix only tests
+ rm -r test/gsl/nmatrix_tests || die
+}
+
+each_ruby_configure() {
+ NARRAY=1 each_fakegem_configure
+}
+
+each_ruby_compile() {
+ NARRAY=1 each_fakegem_compile
+}
+
+each_ruby_test() {
+ NARRAY=1 ${RUBY} -Ilib:test:. -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
+}