summaryrefslogtreecommitdiff
path: root/dev-ruby/rantly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-ruby/rantly
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-ruby/rantly')
-rw-r--r--dev-ruby/rantly/Manifest3
-rw-r--r--dev-ruby/rantly/metadata.xml11
-rw-r--r--dev-ruby/rantly/rantly-2.0.0.ebuild21
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/rantly/Manifest b/dev-ruby/rantly/Manifest
new file mode 100644
index 000000000000..a353a7cff6eb
--- /dev/null
+++ b/dev-ruby/rantly/Manifest
@@ -0,0 +1,3 @@
+DIST rantly-2.0.0.gem 18944 BLAKE2B a124204157953780dfcc97c4777dc3fb7e152eb3f0e208dd18aff80f8252b4f41285ce7870d927433e034678e679e0a735b8796601dd061ce43693f2c3760d50 SHA512 f3eb10eb3fea3135797c57d40bfe6a2ac9d64d4f449850b89072c527913f13eca34507f62ce611831497954b1c28bf5592dc46b73b510503223d029b4b442b74
+EBUILD rantly-2.0.0.ebuild 485 BLAKE2B 155540d908d1f9014f2f033608d9facf7a610080733ea68a1d28828da26fb95d5d2d1ae0ebbfe576f54ad751e19e74e4d5927b650d30652aa7ff2f24c284259c SHA512 e3f7727516c80556e58ecea3543873cdf8ca7483436bad928d36375d049619a24884221ce13d95e3eab1eb91f05cbd210e6b8c616bbc043828c9bbf84222f886
+MISC metadata.xml 342 BLAKE2B 273b8b2ae7aae1dabd053e016a033ae13ff3324266239be086097683a31453ac17a1b70d8368d4b7de8c65ee142e10d80f57a017e4a3ec53386fb001e43eb5f9 SHA512 f70d2c424a55681b36fa019f7b0f5ed8fce8429772485ca91a08b6debb5604fbf613d77c6bc1c3c09b9aa078f20529e521b035bdb66ebaa80ba1e2ce2fbf930d
diff --git a/dev-ruby/rantly/metadata.xml b/dev-ruby/rantly/metadata.xml
new file mode 100644
index 000000000000..a17d9e1e71c4
--- /dev/null
+++ b/dev-ruby/rantly/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rantly-rb/rantly</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rantly/rantly-2.0.0.ebuild b/dev-ruby/rantly/rantly-2.0.0.ebuild
new file mode 100644
index 000000000000..4c2e275a6cc1
--- /dev/null
+++ b/dev-ruby/rantly/rantly-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Imperative Random Data Generator and Quickcheck"
+HOMEPAGE="https://github.com/rantly-rb/rantly"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
+}