summaryrefslogtreecommitdiff
path: root/dev-ruby/rails-dom-testing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/rails-dom-testing
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rails-dom-testing')
-rw-r--r--dev-ruby/rails-dom-testing/Manifest5
-rw-r--r--dev-ruby/rails-dom-testing/metadata.xml11
-rw-r--r--dev-ruby/rails-dom-testing/rails-dom-testing-1.0.8-r1.ebuild27
-rw-r--r--dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3.ebuild26
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/rails-dom-testing/Manifest b/dev-ruby/rails-dom-testing/Manifest
new file mode 100644
index 000000000000..d132dc497100
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/Manifest
@@ -0,0 +1,5 @@
+DIST rails-dom-testing-1.0.8.gem 17408 BLAKE2B 50d786712c8d85426e773d66c6f7ae0f687b6be02579ae52e2a3b61637fd27be08519bee0fd00ca687e7ea2c21ec5633b26e9ef1fefddbe48ea38127349fc1f3 SHA512 313ee52e68878264122aeeb264f2a25eed3b7b1122e1e7ebe0223407e67b6c17e1ce98e6822b5a28fc8b0f3457bbdbe7e3f60cc9d03447a0a1034c151392dab4
+DIST rails-dom-testing-2.0.3.gem 14336 BLAKE2B 8740433474e88a7cb5be14b4357dd0b69d45a39972136cfe9a4d695d2478b5b535e2b407eb0acc9ec3abd633cb1f8591a634abe6eacd8ec38bba865ad32ed92e SHA512 910549bd42e6651b7160af0a4aaffbbdeaee829aa7c3f3552a73ba985ef1230d5586f5bf723018f2cd8c6d5c6238d045a8f3e686704b6989e5a56664061f6c72
+EBUILD rails-dom-testing-1.0.8-r1.ebuild 722 BLAKE2B ed2ea2bc5eebb4997e2eea46287678abf85954f9741ae83c6714eaed9ee03799f179c0526a29f391f4d901dae5eb80cb59ec4ba6a7991491bf0396baed1df314 SHA512 27e7431978afe4cd8366e4f69ba881155f8a129e01f08f5f6e89a03f658da52cbbb139cb45c5a8ca9b28f3ac38dc7e210e00ede8f3dbdadf121f717c8c134489
+EBUILD rails-dom-testing-2.0.3.ebuild 651 BLAKE2B e91d2c4f9e155c92091f4a5084af974dc8bd418388a82ae4126102ddb5dbad2f58787192510d4c4d0f542cd58d84b061ccfb5034f4cb7ec695a59b8c91ade26a SHA512 c0bcf8f1c32f4681b8b81b8d6f348d4e4b7ada3bd3d3f2b8e16fa3d09945b9da8a05319231ef31a87fc87d956e50961801870c10bb9c53c263f15f2577293797
+MISC metadata.xml 350 BLAKE2B 1c2caa318832438e9f00f976edbb95493e9313ecbc0b481cb1ebcbdcac1bd9068eddf8ef6e7becde15efef1e33c6a83a5dcb9b5e20863a6081f10faac65d55a3 SHA512 a0ed76fb694f21c179472ddc7081b3114f9762c65b98cccb47c419dd7626701cbc111205dce3976d54f0fe5811a256da4edd2862bbf075aa62dcc8cd4fbcf21b
diff --git a/dev-ruby/rails-dom-testing/metadata.xml b/dev-ruby/rails-dom-testing/metadata.xml
new file mode 100644
index 000000000000..4334593ccf54
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kaspth/rails-dom-testing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.8-r1.ebuild b/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..d7f1ca77ce09
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/rails-dom-testing-1.0.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
+HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/activesupport:4.2
+ >=dev-ruby/nokogiri-1.6.0 =dev-ruby/nokogiri-1*
+ >=dev-ruby/rails-deprecated_sanitizer-1.0.1"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3.ebuild b/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3.ebuild
new file mode 100644
index 000000000000..3b2e75145dd2
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
+HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activesupport-4.2.0:*
+ >=dev-ruby/nokogiri-1.6"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}