summaryrefslogtreecommitdiff
path: root/dev-ruby/rack-protection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-ruby/rack-protection
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest2
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.0.7.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index ed69c3964ffd..80af67af472f 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,5 +1,7 @@
DIST rack-protection-1.5.5.gem 18432 BLAKE2B abda1313e7e0d04299a689c55241cd92d0f5ed2048395ab79f09ba271100a8dc99fbf5f924e3b3cbe28f318090144539eb0174cc1813d371d9f37df31ab04315 SHA512 c4066a50771247fc89d4ddee44ff87e40a24bad95e914ed2f72cbf9c45152e67e51d2ccc7d1725ade637296a080b06f304157a1a024613a97595b144e03e2e70
DIST rack-protection-2.0.5.gem 16896 BLAKE2B 144888ca499739017ffec494785ca5cba0d1cbfabdf08b11aad4fc88aaaa737408d1801412f05919830c65fd11b2f344f0f758a0334b109174805d5089352521 SHA512 9c4c80a8f70042bea81a67260e26aa25c0a33c73835e4e49cd44c83930f97d8c4d63004d3e39ed631f016e44d66fba238f9c509b0e44eddb2f484d174adea9b4
+DIST rack-protection-2.0.7.gem 16896 BLAKE2B e9d6c91cebc62e6f1efa91a790edc218c78b8336ebcb03ac086e070360be0e5ded4a897042b85bef8e5625dd8c1bf035a825202f0a619f10e584fafce1ab0d0d SHA512 9001bee93859c87060450b83171eab80bf085c0238f978673ac6e31e3e1884a0de1a6d789a61900d1fc429e64f2eb3893e88cf32bef0b3e2a9f58e6f3a3abea1
EBUILD rack-protection-1.5.5.ebuild 690 BLAKE2B 00837887ebd9fd360b9be647ecb2850dcf9d39f9843eb0f20290d075db288fddfc7070c24a324f8bed9c74b98daf153ced7a1c6dae45bdeafd4a46dd4de2d77f SHA512 dafb498a3d11002ce365d26ffec3b2dade3c4e3ab26536035fe2954d32a926128b23ca3a16116ca84821c89e218144cab416f85679401ac28502ab486997e650
EBUILD rack-protection-2.0.5.ebuild 770 BLAKE2B 4775b46794f9679d02f966a03ef181b17a208855facf753af40bb529260cf12724d0dc421a48c1fe17b523d282af84e724629e65e2e22943ed764c0bde6ce6f1 SHA512 1d7cfe140cd1b74af1b90ad308fba167b8a4c1882a9e07ef31a54faed4443dde493acfb97e20b9065fcdb20a76a71e2cd75f7411b6200180e3bca313335457f9
+EBUILD rack-protection-2.0.7.ebuild 723 BLAKE2B 2529a49073eb8a1ea37c2668b8d0561593c9372c428bde54a1a84685d99cdbe6656ab8996e5fd9a8b4058d42af3f28be73374e382b4ff4c73fb8a524471a4697 SHA512 c6dc8e06d8fb3056f12a06579810a4a2bc951a3212037ad02e3eea8fb66b653debbaf12f6eb36256e8ba054fccd5006f46a5b443d027f145d7497a520a9fef43
MISC metadata.xml 488 BLAKE2B 1db94e175d1248a334fa9ff0b5936d0281a1ee2ef69974cc33ba65e19de9ae043e98599a52f5cc55d3e1ca3e5bef3e223cab7f3be0ad9b561b05d81da8c09687 SHA512 ad0122f6e0dde2c02a1af8b8e81a5aebb1a13e0f56dd8f222d6f051da55015a89db0430efa6c1e6b5e193a94ba69d0244498d7cc14f0212f8032393a7f5988b8
diff --git a/dev-ruby/rack-protection/rack-protection-2.0.7.ebuild b/dev-ruby/rack-protection/rack-protection-2.0.7.ebuild
new file mode 100644
index 000000000000..424f35c8363e
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"