summaryrefslogtreecommitdiff
path: root/dev-ruby/rack-protection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-ruby/rack-protection
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest2
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.0.1.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index 457fa8459a9d..a950ed2980f5 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,5 +1,7 @@
DIST rack-protection-1.5.3.gem 18432 BLAKE2B 96daf85f6b51b4a8c8992109ccb0821b9f713166965a6d1392f20a966e3502facc4294c0a824beaa395306e0ba3234902eef717ed839e3e3ca907deedf83370d SHA512 9f94f9f25197c3f8227f5c9c9fd2e896e35bfc08d4a20f4dded9c42772f348d16dceda6916429833b498b29c4dbba4dbb31b1a3cf90de597fb6df2de145d655a
DIST rack-protection-2.0.0.gem 15872 BLAKE2B 706fba47a09565bc973a5dbae3369cb26d02839be92347bb153c5f12054ef605e8e025a0666cb0aa44aae316ba494fffdbb7bbc840dfefff9b3e0b0efd39817a SHA512 cce6a8a64c502e4cfec47ae3d76e71aef42b1eec5aa4802a6c443fcb7a8971a99ad9a5b34fea7ae878630faba10d4f5bde4d9a3eb66f63600fcaf02d9ecc0c2e
+DIST rack-protection-2.0.1.gem 15872 BLAKE2B bd2b17d21767f4f6772400168ddd53491693780b62359d526739580cca66b5b27d4f4c6f419a6ef695ffbef5ff9045bac683c78117765ff784fda136ec102090 SHA512 6dd525384a0027a1943741881168433c63dc2d18093833dffb3417f3f6ccc46d597435a880d297d07751db1c449f3e37942ae03e33d378dbc74caec38c5cf1df
EBUILD rack-protection-1.5.3-r1.ebuild 720 BLAKE2B ad7219b5ad108d2e851eee04ea99dd298d7e0d9e5fcbe79ca1d729b1ff9a9feb956735c6976201e0166d5f7ce7f387cac5cd22e07911d634c52218d74965711c SHA512 03804266f97f678734bc79a95392fd5bd1b9bcb4ff48f0e51294e8fd1feafc2a7dbf8adcbee420f90817b2931a322ebdfc9f8f8d5c3dfd935beacd042cdf6a31
EBUILD rack-protection-2.0.0.ebuild 790 BLAKE2B c6e9c7085f72d26081ce76b3ae5ef7eaf46aa9efcb835cafa00c27e39a77a98706767e6068b60e67287c3936f5ead1b47c6acf57a9b55627a09b2a8247909156 SHA512 f0896ecd0cd997e4ede9ca7f76fe6b680f77c694b49be4b95590b292588fc04000db94c348389ed470e14a26f592d506877ead2e6a629533f3dfd543c4f297f5
+EBUILD rack-protection-2.0.1.ebuild 783 BLAKE2B 3b21814b236d7963b487867257d83464648301cf92f8d619b129b5407af7ce4a93949722b9c38720a8ccf8901b08ec6600db73d9e1f7cf0bc0b545b0c5c32f10 SHA512 40230459e2bfcd3b90b95a1f7a01a8bb7460ae5bb4fd7d2e61c7b14e3aea89c474e20e8547de164c25cc98c9e084765a625ef07661f9fe85c6149c62aba6463d
MISC metadata.xml 488 BLAKE2B 1db94e175d1248a334fa9ff0b5936d0281a1ee2ef69974cc33ba65e19de9ae043e98599a52f5cc55d3e1ca3e5bef3e223cab7f3be0ad9b561b05d81da8c09687 SHA512 ad0122f6e0dde2c02a1af8b8e81a5aebb1a13e0f56dd8f222d6f051da55015a89db0430efa6c1e6b5e193a94ba69d0244498d7cc14f0212f8032393a7f5988b8
diff --git a/dev-ruby/rack-protection/rack-protection-2.0.1.ebuild b/dev-ruby/rack-protection/rack-protection-2.0.1.ebuild
new file mode 100644
index 000000000000..58c4ac881ee6
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"