summaryrefslogtreecommitdiff
path: root/dev-ruby/rack-protection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-ruby/rack-protection
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest2
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.1.0.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index deff4bbd7625..1e2930b58607 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,3 +1,5 @@
DIST rack-protection-2.0.8.1.gem 16896 BLAKE2B 013fc8a5ceaadbfde52a7aca0dab8116cb01d6f034f3370d22a09545885a61adef92ad5ed9f82faf4434507a079ff9a0c3781b906ab6aba69fa032216f276fcb SHA512 264aef904d9ae1c38197ad4ad44f1638905bd180fc4bb402c47856c37168059e8e975ca2de5518b1e5cebf79b970024b7d9f5f8b8908880451357dea5e428562
+DIST rack-protection-2.1.0.gem 17408 BLAKE2B e4804273d346c76e9e7348bfa9575f16c9d415da9db4e8677782aed70fa613b6f322c82808707734276b8db60fce9d87fbbaac807c1b8df7f6bf1960c76ae244 SHA512 965388584a2cae9065ccc0d041bbd40951f22420f05e657586d710f87ae8f854a0be32c3274b9373f96b5f8eb19354d371e3bce9b2df83c013abfea99f16bded
EBUILD rack-protection-2.0.8.1.ebuild 736 BLAKE2B 20d3813d03588afa80cadefbb7bee5edc16e76c567bb811535ebdeffc4c99ba3ffe17d5c27ad1a6b46d5d55d6dd2b090bf8580f38ded35da19c6a4f1e4a3f7b8 SHA512 2486daa5f4559df33aa1ab9b0277ee8feddfca9b946494f46d5f3844760c6b74a35323d0f8e8ac174e6fb364e0ca03e8a42a0c5f8f51c9f8fdf44dae6ca9a6bf
+EBUILD rack-protection-2.1.0.ebuild 730 BLAKE2B a531477bb23513c4e27b00d03b2591371140663fbb618fdcbaeb3d9e31950792ba75f58db2448246e954e9a9cbbf40247eb9c2168c684d3e031af5a82dcd96e0 SHA512 3111e1b8fc22872bf828cc3074969eac1bd478dffb4fcfc19832c3e226f928ac1b1442af4275f8718acdd9ea695431369978f7fd891d52835a033f8dbf5e89ac
MISC metadata.xml 488 BLAKE2B 1db94e175d1248a334fa9ff0b5936d0281a1ee2ef69974cc33ba65e19de9ae043e98599a52f5cc55d3e1ca3e5bef3e223cab7f3be0ad9b561b05d81da8c09687 SHA512 ad0122f6e0dde2c02a1af8b8e81a5aebb1a13e0f56dd8f222d6f051da55015a89db0430efa6c1e6b5e193a94ba69d0244498d7cc14f0212f8032393a7f5988b8
diff --git a/dev-ruby/rack-protection/rack-protection-2.1.0.ebuild b/dev-ruby/rack-protection/rack-protection-2.1.0.ebuild
new file mode 100644
index 000000000000..06b55d8939fa
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"