summaryrefslogtreecommitdiff
path: root/dev-ruby/rack-protection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ruby/rack-protection
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest2
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.2.0.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index 95191aadcf6b..3c154b0b55dd 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,3 +1,5 @@
DIST rack-protection-2.1.0.gem 17408 BLAKE2B e4804273d346c76e9e7348bfa9575f16c9d415da9db4e8677782aed70fa613b6f322c82808707734276b8db60fce9d87fbbaac807c1b8df7f6bf1960c76ae244 SHA512 965388584a2cae9065ccc0d041bbd40951f22420f05e657586d710f87ae8f854a0be32c3274b9373f96b5f8eb19354d371e3bce9b2df83c013abfea99f16bded
+DIST rack-protection-2.2.0.gem 17408 BLAKE2B d9d5d8e2473b6354dd61cfc338a05932a2c60aa12544399cb0b9b74c717d6fa48bdec638381582be0a13f845f0c69583275f412458a20198894b5eddc7b53358 SHA512 06d6c2026e3e93131a2405bbaa8a514ddde48607979828b9fc41309dbdfff2b7c8cac48a6981e76b5dda554f0cbdc7c6ff5f44b8925fce1cb9b7de0a16380ca4
EBUILD rack-protection-2.1.0.ebuild 732 BLAKE2B 57b06570ba613148c27e8b2f9d1fceea1f27d27d87447534d66b3a717fe7262543fc3a62ef1495e0ff6452fc34a5897ccfe325f62eb1d27776ece0e93b392b12 SHA512 1a4e21449e3015b1fd1d23665b270678f15d9c796e4a022a7e5b5749925f180d428cab46356e6220bb35f701588a873ac385c22354f0bf579ba32260fb900630
+EBUILD rack-protection-2.2.0.ebuild 726 BLAKE2B 0a4bfcd1da30f6ad65008e4a2cdc1fc5bdd7330251ebdfd3a993a20327bc8bf699d7fcae3d127d5edb1463dcd8f220fdf7f635b97fb2ff1a6017f3edd06121bd SHA512 b27c24b193464a1f3d9711f9f033a7723ea64e34cc51ce99fc6607c2352a32c0e4caf33ea8713cb6672f789671617d5a95d34328f3d54a488586fac109bef1cd
MISC metadata.xml 489 BLAKE2B 86cb22f6328ceaf077a0e956866b44015fb19dcb81431ce6f219bd7748af6b19b524905e035b2600d385731bc7bb815dc7649e5699bb59626a8269735e853bad SHA512 86816de00c35e3f0d6d0037c9e5519a0b2e8e9a7a926d9a8a056bc04605f28d9aa1fef93279284553a3da68f3d5ce8514763c86cf2b484a28cdc3e41fa5d882b
diff --git a/dev-ruby/rack-protection/rack-protection-2.2.0.ebuild b/dev-ruby/rack-protection/rack-protection-2.2.0.ebuild
new file mode 100644
index 000000000000..d4ddbd88b292
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"