summaryrefslogtreecommitdiff
path: root/dev-ruby/rack-protection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-16 13:45:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-16 13:45:36 +0100
commit29607d91fb1bf1c4456a0b90601ee172ea769283 (patch)
tree71a1c87ff8b0a522d0f8243a4f064f8f9b5d94e4 /dev-ruby/rack-protection
parent22b96ae0ceb12f57b30fc2577770f565506bbac8 (diff)
gentoo auto-resync : 16:07:2022 - 13:45:35
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest2
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.2.1.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index 851654cbbbc9..90cde9e7515c 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,3 +1,5 @@
DIST rack-protection-2.2.0.gem 17408 BLAKE2B d9d5d8e2473b6354dd61cfc338a05932a2c60aa12544399cb0b9b74c717d6fa48bdec638381582be0a13f845f0c69583275f412458a20198894b5eddc7b53358 SHA512 06d6c2026e3e93131a2405bbaa8a514ddde48607979828b9fc41309dbdfff2b7c8cac48a6981e76b5dda554f0cbdc7c6ff5f44b8925fce1cb9b7de0a16380ca4
+DIST rack-protection-2.2.1.gem 17408 BLAKE2B 21ecf95a27ab08b2e89369cfaffff43192c2ca5bb74afe7a91041e5fb9f2479a625ca2fcc59fc2f3eb208f17a3456dffd14095d25f8a0ed331972f6f987dace6 SHA512 595dc7ff7deb63130f966a12849750900319356f29948e9cca1e1aebe168bad77de624dd280a1b804ad6a2d44daedfcb352777ca724e9fde2a5de02ead472734
EBUILD rack-protection-2.2.0.ebuild 732 BLAKE2B dd20f9b311166faf02058ca14b4e6f0c46d197a0b3c5e8c46375c89bdd889919945e2552eae32deadcd407bca3a2ab750ec9eb7bbd87017bf935bdea1641faf7 SHA512 4106892a5dee7c8c44e42e857b7d26d6ae4f702c2c7c5da901cb34953ce0b33d045a2a549239e1f202bc1bc88df7bd2068ceca207196f906e3c2bb0bd653ba6d
+EBUILD rack-protection-2.2.1.ebuild 726 BLAKE2B 4083feb02c0beef7cf258771716e2a70bb6cbc296bc42d39f322f15dbf770303e817faab09cc4e55f06b71e428646676cee19804ee364aa9518fa41d01c50baa SHA512 e7faa9d7d47927db185ab474107800d9e6e6377e95d1caa6cf56ca26c5ca99fbae7473de4ad75c21e0f1cc35d2d452ed9e039713be0694affd6988edbe54669a
MISC metadata.xml 489 BLAKE2B 86cb22f6328ceaf077a0e956866b44015fb19dcb81431ce6f219bd7748af6b19b524905e035b2600d385731bc7bb815dc7649e5699bb59626a8269735e853bad SHA512 86816de00c35e3f0d6d0037c9e5519a0b2e8e9a7a926d9a8a056bc04605f28d9aa1fef93279284553a3da68f3d5ce8514763c86cf2b484a28cdc3e41fa5d882b
diff --git a/dev-ruby/rack-protection/rack-protection-2.2.1.ebuild b/dev-ruby/rack-protection/rack-protection-2.2.1.ebuild
new file mode 100644
index 000000000000..d31bdbd997d7
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"