summaryrefslogtreecommitdiff
path: root/dev-ruby/rack-protection/rack-protection-3.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /dev-ruby/rack-protection/rack-protection-3.0.6.ebuild
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'dev-ruby/rack-protection/rack-protection-3.0.6.ebuild')
-rw-r--r--dev-ruby/rack-protection/rack-protection-3.0.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/rack-protection-3.0.6.ebuild b/dev-ruby/rack-protection/rack-protection-3.0.6.ebuild
new file mode 100644
index 000000000000..d1d2be4d588d
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-3.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://sinatrarb.com/protection/"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"