summaryrefslogtreecommitdiff
path: root/dev-ruby/pygments_rb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/pygments_rb
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/pygments_rb')
-rw-r--r--dev-ruby/pygments_rb/Manifest5
-rw-r--r--dev-ruby/pygments_rb/metadata.xml11
-rw-r--r--dev-ruby/pygments_rb/pygments_rb-1.1.2.ebuild62
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-ruby/pygments_rb/Manifest b/dev-ruby/pygments_rb/Manifest
new file mode 100644
index 000000000000..03c9d889b3ee
--- /dev/null
+++ b/dev-ruby/pygments_rb/Manifest
@@ -0,0 +1,5 @@
+DIST pygments.rb-1.1.2.gem 1169920 SHA256 55a5deed9ecba6037ac22bf27191e0073bd460f87291b2f384922e4b0d59511c SHA512 dee41bf20142b6a63396504b734c183049f84629e7a943bfb361458f6f8d55e9f84ac6c28bac069d839c519eaf562bd73c74e422ebaf750a7430690a8fad043c WHIRLPOOL 9adfa15f5cb9a2d643c860fc52a2250dfdc51c862a031d85908b81af88d5dae1622daecfaf9a9b66c829a542a53a171e806665a0dbec266f5dc5ffbb58008650
+EBUILD pygments_rb-1.1.2.ebuild 1540 SHA256 61d733e53782af67fd2679c4eca99764e5904118cfef3e32141af13e4e73ff8e SHA512 ef10529d30e8038e8aea59c93d86c932bfda000eb8236bc52b4f8ff51b8054b523ca13f7966031b4aea2116a056acfd314e2f8b29a24711dde11237591eca4d9 WHIRLPOOL 69e95d2e76e7b58cfd0be8369113220f71029958b661c0d02c04553a18c07bbfcfa9feeab20203cf9c6a67ad6d3ba22d83032423056a25af1bac6925153c685c
+MISC ChangeLog 2653 SHA256 11e61820a5c5c0d8eed74ffdf9061801948a08c50ab31c55be4b8d32b180c9ac SHA512 a5354b9913985761dcdd69898ee2be2fb490757ce7df897119227120dbc3068ab6eccaba331e663942a1854787cdb7a9859897294b58c8b65dd5ceedaebeeb1f WHIRLPOOL 0a3561dfb600b2f2162c37088e4588bdbed5ebc2195d7175b7d70906801b64730a0ba4541324dd72197f58fedb840ae6357678e842e24aaec84d6ee6898b8688
+MISC ChangeLog-2015 1808 SHA256 8b764fce7737d1293d69811de02af7c33e9d4218aba2826a5ddbf9e7c029d6a4 SHA512 8c1bd3d1d71484fd6057d45cffa6928280d4f9ba28620d0177a968220979ce9e2ae56ca7ae006a4f4c2eb3c605e387cd0b61ced88aed9c6b22b30c99c26bbf9f WHIRLPOOL 88cb10115a7c1e79186f05d8eab3817ba3f8c94a9d6c46de356cedd6dd3d657bb0134c400552efe8df4bc3bb73133ff68250e0fe84e08b807e7591f13009552a
+MISC metadata.xml 342 SHA256 9bb7c5f263c2494c71c432d5a9806120f8edf414fff48b83dda5611f980f2d38 SHA512 aa104434e5ba9d5a27409be91ee791f898e72aa38632b3c185c09071632915686dd5a3ccb46c24c911468d29cdfed6c6421bdfb0119c28bd5c404be4b55bf789 WHIRLPOOL 9343b448390043e2f60ee3a451483554125e4ef7f377288d750d52ad780f969c1c25e7e4f2329a2c37d2a3610ff5dc978840c0a106b3d87982b2fd90af3dea92
diff --git a/dev-ruby/pygments_rb/metadata.xml b/dev-ruby/pygments_rb/metadata.xml
new file mode 100644
index 000000000000..29c1a796cb32
--- /dev/null
+++ b/dev-ruby/pygments_rb/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tmm1/pygments.rb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pygments_rb/pygments_rb-1.1.2.ebuild b/dev-ruby/pygments_rb/pygments_rb-1.1.2.ebuild
new file mode 100644
index 000000000000..13870c620f09
--- /dev/null
+++ b/dev-ruby/pygments_rb/pygments_rb-1.1.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+PYTHON_COMPAT=( python2_7 )
+
+RUBY_FAKEGEM_NAME="pygments.rb"
+MY_P="${RUBY_FAKEGEM_NAME}-${PV}"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${RUBY_FAKEGEM_NAME}.gemspec"
+
+inherit ruby-fakegem python-single-r1
+
+DESCRIPTION="Pygments syntax highlighting in ruby"
+HOMEPAGE="https://github.com/tmm1/pygments.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE+=" ${PYTHON_REQUIRED_USE}"
+
+RUBY_S="${MY_P}"
+
+RDEPEND+="
+ ${PYTHON_DEPS}
+ >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND+=" test? ( ${RDEPEND} )"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.0.0"
+ruby_add_bdepend "dev-ruby/rake-compiler"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '/s.files/d' pygments.rb.gemspec || die
+ python_fix_shebang lib/pygments/mentos.py
+ # we are loosing a "custom github lexer here", no idea what it is,
+ # but if we need it, it should go into dev-python/pygments
+ rm -r vendor lexers || die "removing bundled libs failed"
+}
+
+each_ruby_compile() {
+ # regenerate the lexer cache, based on the system pygments pkg
+ ${RUBY} cache-lexers.rb || die "regenerating lexer cache failed"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_doins lexers
+}