summaryrefslogtreecommitdiff
path: root/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:48:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:48:30 +0100
commit24d75f43d3d4caf76f2448bb277e89a3b3ae0d99 (patch)
tree4f290d635d831599222130ba8ddbf1a726129426 /dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild
parent8d8735134b6bb6e159162e531cccb456691a4ed4 (diff)
gentoo auto-resync : 03.08.2022 - 13:48:05
Diffstat (limited to 'dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild')
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild
new file mode 100644
index 000000000000..68f1eaa1a4b6
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}