summaryrefslogtreecommitdiff
path: root/dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
commit6440e1dd038e7df4f9df7dd5127d3b1c6f39034e (patch)
tree122c8899fbcce481ff7c1deb35c872f0236affa9 /dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild
parente7bc5cacb1abeb6806d255e2a817ab4dcb5f52b8 (diff)
gentoo auto-resync : 09:09:2023 - 10:33:01
Diffstat (limited to 'dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild')
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild b/dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild
new file mode 100644
index 000000000000..dc80c18aca40
--- /dev/null
+++ b/dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
+HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
+
+LICENSE="Apache-2.0"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-typhoeus.patch" )
+
+ruby_add_rdepend "
+ dev-ruby/faraday:2
+ >=dev-ruby/faraday-follow_redirects-0.3.0:0.3
+ dev-ruby/minitar
+ =dev-ruby/semantic_puppet-1*
+"
+
+all_ruby_prepare() {
+ # Avoid integration and user specs since they all require network access
+ rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}