summaryrefslogtreecommitdiff
path: root/dev-ruby/puppet-resource_api
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-20 00:35:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-20 00:35:55 +0000
commit84be07a71d5002585ac714a892bbfd57f3091b4e (patch)
tree0fe24d663efe493f7c44c5dea33b63bb2364e706 /dev-ruby/puppet-resource_api
parent810f2cdadf662a6bfaaed425b6ecd216a301cd3d (diff)
gentoo auto-resync : 20:03:2023 - 00:35:55
Diffstat (limited to 'dev-ruby/puppet-resource_api')
-rw-r--r--dev-ruby/puppet-resource_api/Manifest3
-rw-r--r--dev-ruby/puppet-resource_api/metadata.xml15
-rw-r--r--dev-ruby/puppet-resource_api/puppet-resource_api-1.8.16.ebuild38
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/puppet-resource_api/Manifest b/dev-ruby/puppet-resource_api/Manifest
new file mode 100644
index 000000000000..a10bc7eab5e0
--- /dev/null
+++ b/dev-ruby/puppet-resource_api/Manifest
@@ -0,0 +1,3 @@
+DIST puppet-resource_api-1.8.16.tar.gz 167691 BLAKE2B 58aad4a73ef76fbccab580c1500b4af6a472f9bc9b7b0b1c592626abb837af6b34697194b5da884f87ce306f00f23d6f17ff7926e88ca2df3b0cd5770c819e9c SHA512 b60575d0e4f87425d028429403dd5524e39cb5ffea338871f7c5296d7e632d4eebc6786bdb7005e5c1be5e962115903b11dc9645dacd4d040d3afa43606a3ea2
+EBUILD puppet-resource_api-1.8.16.ebuild 1197 BLAKE2B 8778e334b7d125d0ad137b89b3d38c06a80b7d7b569de2fc1dc5b04b4f83a12517c584f9213b51ac605085fba325cc41b416c3403387160d18efc33b77634efb SHA512 a3fdda65a4ce214e8a691d7a57b11ef198aa686b7f0821cefda9feec578087a62343c5d375752277d985f2b0982d5e84182fda3d1c1cab978970ba366e4a5291
+MISC metadata.xml 458 BLAKE2B 449e3bc9255857c88b86b8983134f8770832019de75a65011dd1fde88caff65ce1f3ea03a569e81592f131c99b029326b032907bbc647efb5fe36ea0609b11f1 SHA512 f7b30a58f12bc9e4546621cc5ca59a84eb78a23aaaf2375edfbc842fa0c8d7b3e466b5f1925a881af8a48af242238adff7fefe029fc78504919f7798b73db55a
diff --git a/dev-ruby/puppet-resource_api/metadata.xml b/dev-ruby/puppet-resource_api/metadata.xml
new file mode 100644
index 000000000000..706558282ad9
--- /dev/null
+++ b/dev-ruby/puppet-resource_api/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">puppetlabs/puppet-resource_api</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/puppet-resource_api/puppet-resource_api-1.8.16.ebuild b/dev-ruby/puppet-resource_api/puppet-resource_api-1.8.16.ebuild
new file mode 100644
index 000000000000..a8e6f8540789
--- /dev/null
+++ b/dev-ruby/puppet-resource_api/puppet-resource_api-1.8.16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md HISTORY.md README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+# rspec tests have dependencies not packaged in Gentoo at this time:
+# puppetlabs_spec_helper
+# CFPropertyList
+# simplecov-console
+# spec-puppet
+# rubocop
+# rubocop-rspec
+# license_finder
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This library provides a simple way to write new native resources for puppet."
+HOMEPAGE="https://rubygems.org/gems/puppet-resource_api https://github.com/puppetlabs/puppet-resource_api"
+LICENSE="MIT"
+# 2023/03/19: .gem does not contain specfiles, and lags behind GitHub releases.
+SRC_URI="https://github.com/puppetlabs/puppet-resource_api/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # the gemspec tries to system(git ls-files) but has a meaningful fallback, so just make it not run git.
+ sed -i -e '/git --help/s,git,false git,g' \
+ "${RUBY_FAKEGEM_GEMSPEC}" \
+ || die
+}
+
+ruby_add_rdepend ">=dev-ruby/hocon-1.0"