summaryrefslogtreecommitdiff
path: root/dev-ruby/pundit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/pundit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/pundit')
-rw-r--r--dev-ruby/pundit/Manifest3
-rw-r--r--dev-ruby/pundit/metadata.xml12
-rw-r--r--dev-ruby/pundit/pundit-1.1.0.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/pundit/Manifest b/dev-ruby/pundit/Manifest
new file mode 100644
index 000000000000..ac2c1775386d
--- /dev/null
+++ b/dev-ruby/pundit/Manifest
@@ -0,0 +1,3 @@
+DIST pundit-1.1.0.gem 22016 BLAKE2B 912f359cb4530c4f65622c3a7bee48a7d84757e4c8327398dbb4e4e170a35f4811c018224aac752b6c2ae54bc93e65b5e0b46f0bb191da57355b55ea0e8d0eaa SHA512 ea7e8ef9e4b280f451810ba193dc5b27a75ecfb050eed674246034ebb687e8302aee8826c022090553b643b41c85adec4d3234f545ab2a59ececa461fe4e4b3a
+EBUILD pundit-1.1.0.ebuild 641 BLAKE2B b1f8b9547eb2ec66ebc01ea235b974d70305c8b7424179287a3b007a98f14bdf3c23ba5427c0f41d9d604b030ac50f63ae179c1958d8d44d39afc0552b5e9e93 SHA512 ed6cdac782cc6ad1a4f07213aaa2ad7918c02938db584fd8786632164af4ddafc938196892f56095e305a0eabd351f61bda53fc9b7626ea6e43a54d27a2aba56
+MISC metadata.xml 376 BLAKE2B 2cd1d4cac40c14c7228ed06fba336f89c6b3e5f5111cc59187ecf3a050a08cd0e77c9b1c5d805374deebcad84f835e52f052dd751481e17c84b59d6dbdac08b2 SHA512 3f0ec90029dbed0d31321b37f959b6a099e73d4d0604bddd2a1fdcf4509a36252cbf0b591aaef793392dad4125440cfdbe807a213200075310223c44c485ec9b
diff --git a/dev-ruby/pundit/metadata.xml b/dev-ruby/pundit/metadata.xml
new file mode 100644
index 000000000000..fd876cbc8d90
--- /dev/null
+++ b/dev-ruby/pundit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">elabs/pundit</remote-id>
+ <remote-id type="rubygems">pundit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pundit/pundit-1.1.0.ebuild b/dev-ruby/pundit/pundit-1.1.0.ebuild
new file mode 100644
index 000000000000..4188266e157f
--- /dev/null
+++ b/dev-ruby/pundit/pundit-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Object oriented authorization for Rails applications"
+HOMEPAGE="https://github.com/elabs/pundit https://rubygems.org/gems/pundit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
+
+ruby_add_bdepend "test? ( >=dev-ruby/actionpack-3.0.0
+ >=dev-ruby/activemodel-3.0.0 )"
+
+all_ruby_prepare() {
+ sed -i -e "/pry/d" spec/spec_helper.rb || die
+}