summaryrefslogtreecommitdiff
path: root/dev-ruby/pundit/pundit-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
commitf9a53aec073578673710687755db617717dd87d3 (patch)
tree9e9642aae0c5bc25cac799d6a2437229bbb76a76 /dev-ruby/pundit/pundit-2.3.0.ebuild
parent7e110ec617b903791c3d309845e11a8b27f441cc (diff)
gentoo auto-resync : 11:07:2023 - 10:29:18
Diffstat (limited to 'dev-ruby/pundit/pundit-2.3.0.ebuild')
-rw-r--r--dev-ruby/pundit/pundit-2.3.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-ruby/pundit/pundit-2.3.0.ebuild b/dev-ruby/pundit/pundit-2.3.0.ebuild
index 0720a534a031..4c7a17a0feb1 100644
--- a/dev-ruby/pundit/pundit-2.3.0.ebuild
+++ b/dev-ruby/pundit/pundit-2.3.0.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
inherit ruby-fakegem
DESCRIPTION="Object oriented authorization for Rails applications"
-HOMEPAGE="https://github.com/elabs/pundit https://rubygems.org/gems/pundit"
+HOMEPAGE="https://github.com/varvet/pundit https://rubygems.org/gems/pundit"
LICENSE="MIT"
SLOT="2"
@@ -26,5 +26,5 @@ ruby_add_bdepend "test? (
)"
all_ruby_prepare() {
- sed -i -e "/pry/d" -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e "/pry/d" -e '/simplecov/,/^end/ s:^:#:' -e '2igem "rack", "~> 2.0"' spec/spec_helper.rb || die
}