summaryrefslogtreecommitdiff
path: root/dev-ruby/ptools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 04:34:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 04:34:53 +0100
commit68d015b395b17126b8651edb61c80fca8c5968c1 (patch)
treee160f0cc1067c3a737fecd75771b2897dde03d39 /dev-ruby/ptools
parent3a77d78ca92715b58ddac074baa5b25c4baf9a9b (diff)
gentoo auto-resync : 10:09:2023 - 04:34:53
Diffstat (limited to 'dev-ruby/ptools')
-rw-r--r--dev-ruby/ptools/Manifest3
-rw-r--r--dev-ruby/ptools/metadata.xml15
-rw-r--r--dev-ruby/ptools/ptools-1.5.0.ebuild23
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/ptools/Manifest b/dev-ruby/ptools/Manifest
new file mode 100644
index 000000000000..c464b5a4f7eb
--- /dev/null
+++ b/dev-ruby/ptools/Manifest
@@ -0,0 +1,3 @@
+DIST ptools-1.5.0.gem 53760 BLAKE2B 49de9513c33dc2840138a88cfc3ab85639426f731138a62c746612715509b6426032e72d59f7789deb3a932de88e81fd0762f744a7abc5be09e782b68eb22647 SHA512 e79b069dc50796ba979c34028d11e65804b398c60328edb349ef6dec6c133166aecc1255fe583bdb06f7b2a7d835de77dd7ec38180d3b23e3f7d321d7e0724e9
+EBUILD ptools-1.5.0.ebuild 545 BLAKE2B 5b8947803c5614b434d7be55afd27c17d1ce477d8ea93c31184b0c25a4347a900ceafce74ee8c3e73d9db3816e827e72178fb9f3aff6e2f8bd6715c282e22bc5 SHA512 ebac437c1b4b869364ea57832ef10aa1044e62065e538e108b4bbcc0c12e4f98007d43e0e3d5f07bfe804dca492a676971c6c94a807ab908a3cf53beb7704fb5
+MISC metadata.xml 443 BLAKE2B 71c4ff262408aa61d651c17e39e0f8732290fb0607b2d4177961b7948378677e4a1391df3605c3ca138ecb7f37b84f96f876c5fd28771f8f3a1aadb480ebd288 SHA512 d9341b9d2f37fe811fd6a4d05e7d5bd907ed13244351bb1c0dcf73e5861626b183d2ee48f7c45f7585f62bf9251decb22bc1d37cdf8769b179f653e16cd2106a
diff --git a/dev-ruby/ptools/metadata.xml b/dev-ruby/ptools/metadata.xml
new file mode 100644
index 000000000000..d79192dd637e
--- /dev/null
+++ b/dev-ruby/ptools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">djberg96/ptools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ptools/ptools-1.5.0.ebuild b/dev-ruby/ptools/ptools-1.5.0.ebuild
new file mode 100644
index 000000000000..b9c0e5c85b5b
--- /dev/null
+++ b/dev-ruby/ptools/ptools-1.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Several handy methods to Ruby's core File class"
+HOMEPAGE="https://github.com/djberg96/ptools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+#ruby_add_bdepend "test? ( dev-ruby/mkmf-lite )"