summaryrefslogtreecommitdiff
path: root/dev-ruby/propshaft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-28 10:32:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-28 10:32:42 +0100
commit5d1fadfaf82053fc45d6120cb990be1ffb05fc8d (patch)
tree8d36fff15d7c7ebb6834f324a115e82f24cdbaf2 /dev-ruby/propshaft
parent5684fb5128e63f45e3c4a58a58ba9b2a124a2a28 (diff)
gentoo auto-resync : 28:10:2023 - 10:32:42
Diffstat (limited to 'dev-ruby/propshaft')
-rw-r--r--dev-ruby/propshaft/Manifest2
-rw-r--r--dev-ruby/propshaft/propshaft-0.8.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/propshaft/Manifest b/dev-ruby/propshaft/Manifest
index 133b26d50607..85ae33eb0f2e 100644
--- a/dev-ruby/propshaft/Manifest
+++ b/dev-ruby/propshaft/Manifest
@@ -1,3 +1,5 @@
DIST propshaft-0.7.0-git.tgz 247111 BLAKE2B aecf4dcab9b57f1933e8f7066f4b229348cf60e4104cc82e14edb945e797a263012fe5b7b65de8ff0165e652256a0bd8fba24af8f08d8e9391050e36e56d5f31 SHA512 3d6dba7a3b5b522f3e4a9f43dc6b9981fbb475374be0b90c8abb2f19c587d025b58876ddb6a9e1b9992e3f357a96b50b6138173d10b8ae131e9457309b8cc0c9
+DIST propshaft-0.8.0-git.tgz 247518 BLAKE2B fe57104a1abd683d74a3166931256f2cdc8e942fffe80c286acfc6db6fa105810bc929f03dd959a660835f030acb580dbd18e7b20f16cfb168b0953731bb2f90 SHA512 3a40355063edb912107ec27ac43ba76746bbd04da04096a4480b43f6fd103bfaec53957d1bbc2bf3d0e08237d965af4d3bf8067b558c4e417ffb506a84f1abff
EBUILD propshaft-0.7.0-r1.ebuild 886 BLAKE2B dd4337e0e54b3f83c88424d888f9c9f587958829be20bff9b06b366771e4610cad6c9f3a5c5097c8224d98a03ebf5e16bb68464387c741248c48835e77349331 SHA512 f78b879e458fad1f42ac15cbed346c60907ccc37606b101d9032495a3c7d8f632d34ae700ab31492c52bedd2ac804c559b4659678831828dfdd7067c1167e8ad
+EBUILD propshaft-0.8.0.ebuild 872 BLAKE2B 2f6632c507dad95b921ee4579858c8b817fe997d94d1d17605529cd6c22ba0896eabc915d523c2074bc0ae8d2414e9a7a28600f667ef5cda1646fe0967d7bd47 SHA512 adc43ec1e4bfcddc926585dbc36c0be1145fb68ed933a57c848bddec3e769e09443659676ec5a5624536652eb9eb2d44d7af87cf4b620ef4fea647174056ab0b
MISC metadata.xml 342 BLAKE2B 33a796157055dd1153d29456dcba2c7ac6ac628d31aee1c2c5a4137c9f4a50ec0dc0b48412f8d4c504b2544d58c059ca14667bc7778c7bfbee0a32d77939714a SHA512 e34f0989d852d8ef12f8dce15bde23f13bad8c5397468c6966ad5535cea9a695729d65097b29ba636387b04501fe5b1f81892f01532da61f4ce65c20728bb39b
diff --git a/dev-ruby/propshaft/propshaft-0.8.0.ebuild b/dev-ruby/propshaft/propshaft-0.8.0.ebuild
new file mode 100644
index 000000000000..9f12429acd24
--- /dev/null
+++ b/dev-ruby/propshaft/propshaft-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="propshaft.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Deliver assets for Rails"
+HOMEPAGE="https://github.com/rails/propshaft"
+SRC_URI="https://github.com/rails/propshaft/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-7.0.0:*
+ >=dev-ruby/activesupport-7.0.0:*
+ dev-ruby/rack:*
+ >=dev-ruby/railties-7.0.0:*
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rails-7.0.0 )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ sed -i -e '/debug/ s:^:#:' Gemfile || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}