summaryrefslogtreecommitdiff
path: root/dev-ruby/propshaft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ruby/propshaft
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ruby/propshaft')
-rw-r--r--dev-ruby/propshaft/Manifest5
-rw-r--r--dev-ruby/propshaft/metadata.xml11
-rw-r--r--dev-ruby/propshaft/propshaft-0.6.1.ebuild36
-rw-r--r--dev-ruby/propshaft/propshaft-0.6.4.ebuild38
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-ruby/propshaft/Manifest b/dev-ruby/propshaft/Manifest
new file mode 100644
index 000000000000..0f8394d04f53
--- /dev/null
+++ b/dev-ruby/propshaft/Manifest
@@ -0,0 +1,5 @@
+DIST propshaft-0.6.1-git.tgz 245087 BLAKE2B 6e04ebc0315c263f79dbfc9f836b270b8b693e1a7e332a97d8abe5cc6555d0acc9efe3ae7979c901ca2c502460e8ee67b83420863d5dabdf50fbc2028aacd5b9 SHA512 35600b7e051810c7f0798f29faab7c7bcabf04198fc56ee9a4492d18ddfabf543cfbf11c28f35eb5e2a64eb57c65b95567e00441852ac0f29d8538ad8d5cb1b4
+DIST propshaft-0.6.4-git.tgz 245384 BLAKE2B 8089c7ee8f8d41f761a31bcd4751899da86302cdf7e1d5a9ba673e8a64431b0e35bbfa7d09fb0caa5ca06457b7134f27c3f37ade213922d616b374adac9824c5 SHA512 3302e1a0ef4bd47094566b393db77f1181e3e3b67c08b18694cea48b4518a45893dc16238ce1d86965d0b37894069ddbe7040392e7cdcad5caa80d7ff86bf2eb
+EBUILD propshaft-0.6.1.ebuild 776 BLAKE2B dc42f57b81b2a982690f66af4337865360487568f43cc3bc8c8e80c1169c50d399eb0d10afd8380f6a9da78db32ebf7857e725e9d38b2aa2257bee0a852fe352 SHA512 7b32013085bb5851985a0bbd609e930d5331b6f15cd5c03c455dfa73a1955465ac8e1387962af1f5b54c6ea4388d2409c844dd8c0f0c17e629fce49c47f860b0
+EBUILD propshaft-0.6.4.ebuild 829 BLAKE2B 65e19b1126590da5214286dc7c0db730bf4795cb9d335d0e7c39d960b7a3f34e18def823c4abeb634991040acb7499daaa431ac1125c1d16809f94a0e6e2a2a1 SHA512 81fa72b5ffc95aae355f3b8e09e2d38269aabb5c140a0e2be3598c1ee609107304db10ad6e1616b445f96734b9a3b12c8534a59d67c001a68d5291fb8d45c2f2
+MISC metadata.xml 342 BLAKE2B 33a796157055dd1153d29456dcba2c7ac6ac628d31aee1c2c5a4137c9f4a50ec0dc0b48412f8d4c504b2544d58c059ca14667bc7778c7bfbee0a32d77939714a SHA512 e34f0989d852d8ef12f8dce15bde23f13bad8c5397468c6966ad5535cea9a695729d65097b29ba636387b04501fe5b1f81892f01532da61f4ce65c20728bb39b
diff --git a/dev-ruby/propshaft/metadata.xml b/dev-ruby/propshaft/metadata.xml
new file mode 100644
index 000000000000..51bcb44a79fe
--- /dev/null
+++ b/dev-ruby/propshaft/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rails/propshaft</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/propshaft/propshaft-0.6.1.ebuild b/dev-ruby/propshaft/propshaft-0.6.1.ebuild
new file mode 100644
index 000000000000..7bfc73881f6a
--- /dev/null
+++ b/dev-ruby/propshaft/propshaft-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="propshaft.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Deliver assets for Rails"
+HOMEPAGE="https://github.com/rails/propshaft"
+SRC_URI="https://github.com/rails/propshaft/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-7.0.0:*
+ >=dev-ruby/activesupport-7.0.0:*
+ dev-ruby/rack:*
+ >=dev-ruby/railties-7.0.0:*
+"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ sed -i -e '/debug/ s:^:#:' Gemfile || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/propshaft/propshaft-0.6.4.ebuild b/dev-ruby/propshaft/propshaft-0.6.4.ebuild
new file mode 100644
index 000000000000..2573dcf1599e
--- /dev/null
+++ b/dev-ruby/propshaft/propshaft-0.6.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="propshaft.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Deliver assets for Rails"
+HOMEPAGE="https://github.com/rails/propshaft"
+SRC_URI="https://github.com/rails/propshaft/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-7.0.0:*
+ >=dev-ruby/activesupport-7.0.0:*
+ dev-ruby/rack:*
+ >=dev-ruby/railties-7.0.0:*
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rails-7.0.0 )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ sed -i -e '/debug/ s:^:#:' Gemfile || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}