summaryrefslogtreecommitdiff
path: root/dev-ruby/power_assert/power_assert-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-02 05:16:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-02 05:16:35 +0100
commit6882d8d1110ef4feeec532196a1f0a25420d0fd1 (patch)
treec8a3d28a31e6c077d6b9097ff36b1232d2ce04b7 /dev-ruby/power_assert/power_assert-2.0.1.ebuild
parent85a2a2153ef8027c2ba1be45143cd91914be0ad0 (diff)
gentoo auto-resync : 02:04:2023 - 05:16:35
Diffstat (limited to 'dev-ruby/power_assert/power_assert-2.0.1.ebuild')
-rw-r--r--dev-ruby/power_assert/power_assert-2.0.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/power_assert/power_assert-2.0.1.ebuild b/dev-ruby/power_assert/power_assert-2.0.1.ebuild
deleted file mode 100644
index 12835b10bbca..000000000000
--- a/dev-ruby/power_assert/power_assert-2.0.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="power_assert.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Shows each value of variables and method calls in the expression"
-HOMEPAGE="https://github.com/ruby/power_assert"
-SRC_URI="https://github.com/ruby/power_assert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="|| ( Ruby BSD-2 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-SLOT="0"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
- sed -i -e '1igem "test-unit"' \
- -e '/byebug/ s:^:#:' test/test_helper.rb || die
-
- # Avoid git dependency
- sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid circular dependency on byebug when bootstrapping ruby
- sed -i -e '/byebug/ s:^:#:' -e '/test_core_ext_helper/ s:^:#:' test/test_helper.rb || die
- rm test/test_core_ext_helper.rb test/trace_test.rb || die
-
- # Avoid circular dependency on pry when bootstrapping ruby
- sed -i -e '/pry/ s:^:#:' -e '/test_colorized_pp/,/^ end/ s:^:#:' test/block_test.rb || die
-}