summaryrefslogtreecommitdiff
path: root/dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild')
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild
new file mode 100644
index 000000000000..61f75a2bf234
--- /dev/null
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.15-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library that implements a subset of the Ruby 1.9 Process::spawn"
+HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e '/test_backtick_redirect/askip "Output depends on bash version"' test/test_backtick.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
+}