summaryrefslogtreecommitdiff
path: root/dev-ruby/polyglot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/polyglot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/polyglot')
-rw-r--r--dev-ruby/polyglot/Manifest3
-rw-r--r--dev-ruby/polyglot/metadata.xml13
-rw-r--r--dev-ruby/polyglot/polyglot-0.3.5.ebuild25
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/polyglot/Manifest b/dev-ruby/polyglot/Manifest
new file mode 100644
index 000000000000..5fcacb552a8d
--- /dev/null
+++ b/dev-ruby/polyglot/Manifest
@@ -0,0 +1,3 @@
+DIST polyglot-0.3.5.gem 8192 BLAKE2B c9f78c05109345e09aa0d0c899e551e67ce7bf191ef00bf169cb05c9860ab538e303fa177c6aec8ac9944bd3ad4263fbf0819af0fa190e989caad1c75c1e5377 SHA512 405790c8edf5a98010334a62f7efeddd60f6dcff91ad5ff599579be3201a7e1b359787da59523a612fed5ccf8385116865316fa8872f0350e33dc078410a54cf
+EBUILD polyglot-0.3.5.ebuild 708 BLAKE2B f14652c06a6d12d1545b7d9cd1e72a62e5047970461ab7c378b71f7777ecdb341377ed970929a6d0b7fd7269b8585bcaa49998705f3c502275869d46a235d42a SHA512 73ae570e898bcdb9b306d2c84cfd32149d7c6b8d99ab501c5ec05a7c2b1ba97c457ec4a4b3fdeb6081a95856f191f96f82f07af0e49c0a9b7fcf724e22095856
+MISC metadata.xml 475 BLAKE2B 64c33e4ace7dd9a38c5048af6505b118a4c9b883833f9c701423201f418b5d2d21f955d7d584555cc7b350dc0f0d861472acca063a794b73d7443378e2a7f2ea SHA512 94e0a25efd37c4e396d86ecf8eae9233edaaca6796190e4d12c7a88922606cae6a9fee0d69bee6ef8d3909f2e18ef5d2c80d6334b06a6febf1fdcab5d5313fe2
diff --git a/dev-ruby/polyglot/metadata.xml b/dev-ruby/polyglot/metadata.xml
new file mode 100644
index 000000000000..ba3d9272319e
--- /dev/null
+++ b/dev-ruby/polyglot/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <longdescription>
+Polyglot provides support for fully-custom DSLs by providing a
+registry of file types that can be loaded by its improved version of
+'require', using a custom loader for each file type.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/polyglot/polyglot-0.3.5.ebuild b/dev-ruby/polyglot/polyglot-0.3.5.ebuild
new file mode 100644
index 000000000000..f72b633b64e8
--- /dev/null
+++ b/dev-ruby/polyglot/polyglot-0.3.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Polyglot provides support for fully-custom DSLs"
+HOMEPAGE="http://polyglot.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ # jruby has trouble parsing this metadata and there are no dependencies.
+ rm -f ../metadata || die
+}