summaryrefslogtreecommitdiff
path: root/dev-ruby/polyglot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/polyglot
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/polyglot')
-rw-r--r--dev-ruby/polyglot/Manifest5
-rw-r--r--dev-ruby/polyglot/metadata.xml13
-rw-r--r--dev-ruby/polyglot/polyglot-0.3.5.ebuild25
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/polyglot/Manifest b/dev-ruby/polyglot/Manifest
new file mode 100644
index 000000000000..ef50c00823f5
--- /dev/null
+++ b/dev-ruby/polyglot/Manifest
@@ -0,0 +1,5 @@
+DIST polyglot-0.3.5.gem 8192 SHA256 59d66ef5e3c166431c39cb8b7c1d02af419051352f27912f6a43981b3def16af SHA512 405790c8edf5a98010334a62f7efeddd60f6dcff91ad5ff599579be3201a7e1b359787da59523a612fed5ccf8385116865316fa8872f0350e33dc078410a54cf WHIRLPOOL 80c82c69182899d3f220b713b4cf59f9ea4c35c3e2bfcdaa1e659b36545b06057ee89ffc9870a3d6757c3904e8058e8e41969fc210513d666521895d2d747c96
+EBUILD polyglot-0.3.5.ebuild 701 SHA256 1e4bbbdcbff0e020424584e73aacc4bfac20415cabf7536312f099bd535484e3 SHA512 60f64705fea03c9f48d047749b2edd928d8867b1a60c2da1c6a6af8a28450d4d5eefa09af504ace196715cec0ec19a65174e4ebdd68b9491a08bf8332713bf86 WHIRLPOOL 6eb54bb7361c9933458dc04be0651d0a777539f649f7c219cdf889fba5e6e6de14a2321f9aab1cce6e16e39ae2ba946225a6bd345ee8f0c1e02566dcca65d297
+MISC ChangeLog 3228 SHA256 13c37c8b95aad1ef64351ca2dd5fae9380931fad455a8c0c025cb64a72741957 SHA512 4b78733ad38884d69112e9c1453d51932f9dcb7ae08d2c1ab75d391e2574d822c430e52e524c9bf7929bc87fbfa8acec166c3f71812046178e19e8ec1030297f WHIRLPOOL 4a90387b901b2f2761f8d2721e0e8366eb6404a8ad055f07f7ea8e7f0b127d86c703ee34484ef7cc2597b404040fb833d9cb965afb139678dcee5bce6fbc1dac
+MISC ChangeLog-2015 4468 SHA256 8a6288cb05fc29c8fa256856bd5a7dee65232d57294fa294c0b4c8119d78f811 SHA512 0728ee70bc18465391bafed89eb1e37a48ebc77f7af152c7718fa459960215143c17c3d87bbe89c83f14217328223e7bd59b3d041dfc7ab2a9930e19e66b4725 WHIRLPOOL e4635bafde6c18a435319efc98110fd77ae0c1bfa258d6c749e0ea7a6abf732c55f33772a91c691c8bd7ee1fe7ff4bacca37ac121eacb4711040b480e66cbf72
+MISC metadata.xml 475 SHA256 af5a7135b73a332cff2d8e7fdf5b79f2755258a5fa0802c3e6c6e46fb1ac014a SHA512 94e0a25efd37c4e396d86ecf8eae9233edaaca6796190e4d12c7a88922606cae6a9fee0d69bee6ef8d3909f2e18ef5d2c80d6334b06a6febf1fdcab5d5313fe2 WHIRLPOOL 6890046fc3ef24f1ffd77bd64a248bd4cfea4db2c6168790b9c476d9380878f2feeb0faef203fb99f8cae825cb7b01eacf5ca20763ba22268feca3e90462ce60
diff --git a/dev-ruby/polyglot/metadata.xml b/dev-ruby/polyglot/metadata.xml
new file mode 100644
index 000000000000..ba3d9272319e
--- /dev/null
+++ b/dev-ruby/polyglot/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <longdescription>
+Polyglot provides support for fully-custom DSLs by providing a
+registry of file types that can be loaded by its improved version of
+'require', using a custom loader for each file type.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/polyglot/polyglot-0.3.5.ebuild b/dev-ruby/polyglot/polyglot-0.3.5.ebuild
new file mode 100644
index 000000000000..b32f17427c34
--- /dev/null
+++ b/dev-ruby/polyglot/polyglot-0.3.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Polyglot provides support for fully-custom DSLs"
+HOMEPAGE="http://polyglot.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ # jruby has trouble parsing this metadata and there are no dependencies.
+ rm -f ../metadata || die
+}