summaryrefslogtreecommitdiff
path: root/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-18 07:47:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-18 07:47:30 +0100
commitdef1d9264911de9f80db5165882084b0d66c9208 (patch)
treeef3e26d68bba8ecff4d26e39eab07bed5432ecde /dev-ruby/pkg-config/pkg-config-1.5.2.ebuild
parent81ab1a4db30480fdfb51d6e784b0f3ad9bbe2432 (diff)
gentoo auto-resync : 18:06:2023 - 07:47:30
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.5.2.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.5.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild b/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild
new file mode 100644
index 000000000000..d553cc41ba97
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/ruby-gnome/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ sed -e '/test_cflags/aomit "Fragile on Gentoo"' -i test/test-pkg-config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test-pkg-config.rb || die
+}