summaryrefslogtreecommitdiff
path: root/dev-ruby/pg/pg-0.21.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /dev-ruby/pg/pg-0.21.0.ebuild
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'dev-ruby/pg/pg-0.21.0.ebuild')
-rw-r--r--dev-ruby/pg/pg-0.21.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-ruby/pg/pg-0.21.0.ebuild b/dev-ruby/pg/pg-0.21.0.ebuild
index 5309a54327c3..24430c4f4590 100644
--- a/dev-ruby/pg/pg-0.21.0.ebuild
+++ b/dev-ruby/pg/pg-0.21.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -23,6 +23,8 @@ RDEPEND+=" dev-db/postgresql:*"
DEPEND+=" dev-db/postgresql
test? ( >=dev-db/postgresql-9.4[server,threads] )"
+PATCHES=( "${FILESDIR}/postgresql10-tests.patch" )
+
all_ruby_prepare() {
# hack the Rakefile to make it sure that it doesn't load
# rake-compiler (so that we don't have to depend on it and it