summaryrefslogtreecommitdiff
path: root/dev-ruby/patron
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-ruby/patron
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/Manifest2
-rw-r--r--dev-ruby/patron/patron-0.13.3.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/patron/Manifest b/dev-ruby/patron/Manifest
index cfa0f22e80a2..2ae138669f74 100644
--- a/dev-ruby/patron/Manifest
+++ b/dev-ruby/patron/Manifest
@@ -1,3 +1,5 @@
DIST patron-0.13.1.gem 64512 BLAKE2B 14f691cb0fd1c863a1ef634ba8aee94751095138e940f13bf09860e9e0061872fe14fa33416f59f82d4adc53963721d653936a3f058b27654ea7593d6068d0b7 SHA512 7b082ff7442c2635c38b37132cd61f6cd18d4792d41cbf3bed1201fb7371b75bb628a295f4e3dd173c23e086d3c1f54f0217df3f7d1a30c1031fcca86269e1e7
+DIST patron-0.13.3.gem 65024 BLAKE2B 87aa69aab49978d14a80ed9e09d74d7853da3512875cc3aecd3f387d1523b85c84625b57a5826e5f5f999cec4feaae58c1aaae96582144a5c9dc537c9d5a4224 SHA512 afbbbd9570e338a5d1b97b4ebeda76ac95a22c29d908629723d345a47400183c2ccee67ebcaf5b6f9ecb032eb3b847e70ec9eebff75b33045a3665c215abfbd0
EBUILD patron-0.13.1-r1.ebuild 1250 BLAKE2B ed6fe6a7f5be66a4aa9c2212225d1283a0798c6de787fcfd59a853630b82c1bea3ca7a0f98641b01e6c193a0d6326d991d92f66813c69d9728bef4013e9e052c SHA512 90f5e7269dd0e93cace60443f3f399f3ae0f5141c93a039ba276389ba931c94675981a13b5e17bb481e642563ecb91876da3f87d1aa885d57d01128f88ec5292
+EBUILD patron-0.13.3.ebuild 1245 BLAKE2B 22e88a599244a238d0248e61849739e36520fc158a2eba708d9806de60de307d194d82498c51bf991846c33e23f6b1da4a606cafbe8da7553c1f5d2b39d1eb52 SHA512 8cb4ccdf7868581e8247149a90049574cfa5268c548798b463f0095462dfa914a6f0b80ec46a2ef057eed061aa981d9062125f40bc6cba53676d2c0486359347
MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/patron/patron-0.13.3.ebuild b/dev-ruby/patron/patron-0.13.3.ebuild
new file mode 100644
index 000000000000..cedf0130468e
--- /dev/null
+++ b/dev-ruby/patron/patron-0.13.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="https://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+ruby_add_bdepend "test? ( www-servers/puma )"
+
+all_ruby_prepare() {
+ # Fix Rakefile
+ sed -i -e 's:rake/rdoctask:rdoc/task:' \
+ -e 's/README.txt/README.md/' \
+ -e '/bundler/I s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ Rakefile || die
+
+ # Avoid specs with failures. We were not running any specs before.
+ rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}