summaryrefslogtreecommitdiff
path: root/dev-ruby/path_expander/path_expander-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 21:54:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 21:54:24 +0100
commitda491770b9ba5f179e18db461c49cb6f1ccf0e1f (patch)
treed3e34a8bd906741ab18cf69d8d4f732853e26ade /dev-ruby/path_expander/path_expander-1.1.0.ebuild
parentad6182343997a405079870a2fe91c4e0c6b94595 (diff)
parent5a165c60b9b8c4847067cb83b4be7da785d01f93 (diff)
gentoo resync : 28.09.2019
Diffstat (limited to 'dev-ruby/path_expander/path_expander-1.1.0.ebuild')
-rw-r--r--dev-ruby/path_expander/path_expander-1.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/path_expander/path_expander-1.1.0.ebuild b/dev-ruby/path_expander/path_expander-1.1.0.ebuild
new file mode 100644
index 000000000000..6c8722ce1e1e
--- /dev/null
+++ b/dev-ruby/path_expander/path_expander-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pre-process CLI arguments expanding directories into their constituent files"
+HOMEPAGE="https://github.com/seattlerb/path_expander"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="1"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix tests depending on sort order
+ sed -i -e '/test_process_args_dir/,/^ end/ s:^:#:' \
+ -e '33 s/$/.sort/' \
+ -e '83 s/act/act.sort/' \
+ test/test_path_expander.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}