summaryrefslogtreecommitdiff
path: root/dev-ruby/ox/ox-2.14.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 09:07:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 09:07:02 +0000
commit68f980204de6c2d69eed8748edc90282879326a6 (patch)
treeeb74f0bcca207f547c8ababe0f82e65e16b30ce1 /dev-ruby/ox/ox-2.14.14.ebuild
parentc8273339188289fe8571e5a8cb9e00e59a46aaaf (diff)
gentoo auto-resync : 02:02:2023 - 09:07:02
Diffstat (limited to 'dev-ruby/ox/ox-2.14.14.ebuild')
-rw-r--r--dev-ruby/ox/ox-2.14.14.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/ox/ox-2.14.14.ebuild b/dev-ruby/ox/ox-2.14.14.ebuild
new file mode 100644
index 000000000000..d15b4d7c3d8c
--- /dev/null
+++ b/dev-ruby/ox/ox-2.14.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="ox.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ox/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/ox
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast XML parser and Object marshaller"
+HOMEPAGE="https://www.ohler.com/ox/ https://github.com/ohler55/ox"
+SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} test/tests.rb || die
+}